Focal Point
[SOLVED]Cannot connect to WebFocus Environment->localhost

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/1381057331/m/1177066236

August 06, 2013, 06:55 AM
Praveen Kumar
[SOLVED]Cannot connect to WebFocus Environment->localhost
Hi All,

I have installed WebFocus 8.0.0.3 in my system and when I open it, I cannot connect to WebFocus Environment->localhost and my 'Project on Localhost' is kind of disabled.

My Apache Tomcat 7.0 starts and stops within a second saying that some services stops automatically if they have no work to do.

And my WebFocus 80 Server for Developer Studio failed to start.

Can you plz help me in fixing this?.

This message has been edited. Last edited by: <Emily McAllister>,
August 06, 2013, 04:58 PM
Kamesh
Try to start the server in command mode. It will tell you, what is missing?


WFConsultant

WF 8105M on Win7/Tomcat
August 06, 2013, 05:43 PM
Waz
You can also check the WebFOCUS server log, edaprint, and also the tomcat logs for any errors


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.05OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

August 07, 2013, 09:29 AM
iWay Newbie
Hi Praveen,

Sounds like you're having connection problems with DevStudio.

If you have not had to recreate the connections to the server, it probably means your old wfscom.xml file was kept from the previous release. Try to remove this file, it will be recreated when your start DevStudio again and add your new environments.

Delete the file wfscom.xml that is in the following location:

 %USERPROFILE%\AppData\Roaming\Information Builders


or for older OS on:

 %USERPROFILE%\Application Data\Information Builders


Then start DevStudio and create your environment again. The file will be recreated with the new format.

Let us know if that helps you connect.

NG


--
iSM 6 on AIX,
iSM 6 on Windows 2008 Server
WebFOCUS 8.0.03 on AIX
August 07, 2013, 10:38 AM
jnc
The issue is with Tomcat. If it doens't stay started, then WebFOCUS isn't going to work.

I would start by checking the java configured for tomcat. start, information builders, tomcat, tomcat configuration utility, click the java tab. verify that version of java exists, and is a supported java version. or, hardcode in a path to another installed java, and see if tomcat stays up.

if you hardcode it, it's a value like.....
c:\Program Files\Java\jdk1.6.0_17\jre\bin\server\jvm.dll
Tomcat has to stay up, for localhost to work


WebFocus 7x, 8x, Win / Linux, any output format
August 07, 2013, 01:29 PM
<Kathryn Henning>
Hi Praveen,

This is a known issue with the Developer Studio 8.0.03 package that was originally posted on the software download site. Tomcat is not being configured correctly. Please open a case on InfoResponse Online so that we can walk you through updating the Tomcat configuration.

Please note that this issue has been corrected in the Developer Studio 8.0.03 version currently available for download. Re-downloading and installing is another way to correct this.

Update: If you will be downloading and reinstalling, please ensure that you remove Developer Studio and Tomcat before starting the install.

We're sorry for any inconvenience this has caused you. We are notifying specific customers impacted by this.

Regards,

Kathryn

This message has been edited. Last edited by: <Kathryn Henning>,
August 08, 2013, 12:01 PM
Kamesh
How to find the correct version (bug free) of developer studio?

You mentioned as "known issue with the Developer Studio 8.0.03 package" and it has been corrected in the Developer Studio 8.0.03 version.

If I download it 2 weeks back then do I have the corrected version?


WFConsultant

WF 8105M on Win7/Tomcat
August 08, 2013, 01:17 PM
<Kathryn Henning>
Hi Kamesh,

This issue was corrected in the Developer Studio download package with a date of 08/05/2013.

Please note that this only occurs if Tomcat is installed and configured through the Developer Studio installation. The issue does not occur if Tomcat was installed with an earlier 8002 Developer Studio package or if it was installed through WebFOCUS.

UPDATE: Apache Tomcat can also get started and stopped through a command window by running the jobs:
{CATALINA_HOME}\bin\startup.bat and {CATALINA_HOME}\bin\shutdown.bat
where {CATALINA_HOME} is the home directory of your Apache Tomcat installation e.g. c:\ibi\tomcat\

Regards,

Kathryn

This message has been edited. Last edited by: <Kathryn Henning>,
September 01, 2016, 05:05 AM
Kranthi Kumar
Hi Newbie,

I am also facing this issue but i deleted wfscom.xml file in the following location

%USERPROFILE%\AppData\Roaming\Information Builders

Then again i entered Localhost credentials(admin) then that
wfscom.xml new file is created but i am unable to connect Webfocus Environment.

Showing Error 12029-Unable to connect Webfocus Environment

Warm Regards,
Kranthi Kumar.


WebFOCUS 8
Windows 7, HTML, PDF
September 14, 2016, 08:22 AM
Tamra
quote:
12029-Unable to connect Webfocus Environment


Hi Kranthi,

Welcome to Focal Point!

This an older topic and may not be reviewed by the original owner.
Also, this is the iWay Forum but the topic seems to be related Dev Studio.

If this is with Dev Studio then make sure your environment is set correctly.

Open DevSTUDIO -> File -> Show Environments -> Pick the environment -> Click
properties -> Web Component -> Port -> Web Component Authentication dropdown

Also make sure no credentials are specified on the "WebFOCUS" component within
the environment properties.

Please verify the following....

WebFOCUS client may have also rejected your
userid as having insufficient permission to use DevSTUDIO against that
environment.

Please make sure your user belongs to a group that is granted the appropriate
DevSTUDIO permissions through a role.

Make sure all your services are running such as Tomcat and Reporting Server.

Thank you for participating in the Focal Point Forum.

Kind Regards,
Tamra Colangelo
IBI Focal Point Moderator


WebFOCUS 8x - BI Portal, Developer Studio, App Studio, Excel, PDF, Active Formats and HTML5
September 14, 2016, 08:33 AM
Kranthi Kumar
Hi Colangelo,

Thanks for sharing your valuable information.

Now the issue is resolved.


Regards,
Kranthi Kumar.


WebFOCUS 8
Windows 7, HTML, PDF