Focal Point
XFocus - Prior to Load Option

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/1381057331/m/3127016526

October 29, 2012, 10:55 AM
Koby1Kanoby
XFocus - Prior to Load Option
I have a flow that loads data in to an XFocus target.

Prior to Load Option needs to be set to Drop Table.

In scenarios where there are no records existing in the source, the Prior to Load Option Drop Table is NOT being executed.

This is creating bad data, as subsequent flows are using the old data in the XFocus file.

Any advise would be most appreciated.


WebFOCUS 7.6
Windows, All Outputs
October 30, 2012, 09:01 AM
Clif
It's helpful if you identify the product you are using which appears to be DataMigrator.

Right click on the work flow and select Flow Properties. Then under Execution UNCHECK the checkbox for "Stop if 0 rows selected" and then the flow will drop the target and complete successfully, even with no data.
October 30, 2012, 10:00 AM
Koby1Kanoby
Hi Clif,

Unfortunately, I do not get an "Execute" attribute group, or a "Stop if 0 rows selected" attribute checkbox when selecting "Properties" for the flow, or any of the flow objects.

I'm using Data Management Console Release R727703B 32 bit.


WebFOCUS 7.6
Windows, All Outputs
October 30, 2012, 02:35 PM
Clif
Back then the context menu choice was just called Properties; on the data flow tab don't select an object, just right click on an empty area of the flow.

You could also click the first button on the Data Flow toolbar with tool tip Flow Properties.

If you still can't find it please call the hotline.
October 30, 2012, 04:19 PM
Koby1Kanoby
OK, found it!

Thanks for your help Clif.


WebFOCUS 7.6
Windows, All Outputs