Focal Point
Question about Connectors for JCA and XI. Also Help

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/1381057331/m/3191091422

April 19, 2007, 11:41 AM
rafas
Question about Connectors for JCA and XI. Also Help
Helo

Im evaluating iWay adapters between SAP XI and Baan.

First I have a Question.
Does iWay Connector for XI depends of Connector for JCA?

I ask because the JCA Test Tool deployed in SAP XI doesn't work and I want to concentrate in Connector for XI.

Second
I have installed and configured the Connector for XI but when I send a synchronous message to Baan those messages are shown in message monitoring.

Unable to forward message to JCA adapter; creation of JCA connectio failed. Reason: null

com.sap.aii.af.ra.ms.api.DeliveryException: Adapter call failed. Reason: null


And when i monitor the communication channel using iWay adapter to Baan with the runtime monitoring I see the following:

Communication Channel: CC_ManufacturingItem_rcv
Status: n/a
Short Log: No adapter registered for this channel

Thank you a lot for your time
May 18, 2007, 03:02 PM
Kerry
Hi rafas,

Here are suggestions from internal resources:

quote:
First I have a Question.
Does iWay Connector for XI depends of Connector for JCA?


Response: Can we assume that you mean the iWay XI adapter not connector? The adapter(.sda) has nothing to do with the JCA test tool as far as deployment.

quote:
Second
I have installed and configured the Connector for XI but when I send a synchronous message to Baan those messages are shown in message monitoring.

Unable to forward message to JCA adapter; creation of JCA connectio failed. Reason: null

com.sap.aii.af.ra.ms.api.DeliveryException: Adapter call failed. Reason: null


And when i monitor the communication channel using iWay adapter to Baan with the runtime monitoring I see the following:

Communication Channel: CC_ManufacturingItem_rcv
Status: n/a
Short Log: No adapter registered for this channel


Response: Please check the Java Visual admin screen to see if the Baan application (iWay Baan adapter) is deployed and running. If running, then you should check the metadata deployment. The metadata namespace must be the same as the name within the type element inside the metadata.xml file deployed with the .sda.


Hope this helps. Smiler

Cheers,

Kerry


Kerry Zhan
Focal Point Moderator
Information Builders, Inc.