Focal Point
[CLOSED] SQL Object and Insert into Decimal field (iIT / SM)

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/1381057331/m/3277095486

November 16, 2016, 09:19 AM
DipJen
[CLOSED] SQL Object and Insert into Decimal field (iIT / SM)
I am trying to insert incoming xml into sql server and its failing at the insert where xml has no value and attribute null="y",and field in sql is decimal so inserting '' empty string is not valid and throwing following error. Is there way to insert null instead of '' string. I tried _qual function.

Error: Error converting data: type varchar to numeric

tried: _qval(xpath(//row/total_amount),'single','null') still gets replaced with ''

Can someone help in how to insert into decimal field as default of null not ''?

This message has been edited. Last edited by: Tamra,


WebFOCUS 8
Windows, All Outputs
November 25, 2016, 04:21 PM
Tamra
quote:
SQL Object and Insert into Decimal field (iIT / SM)



There error msg is referring to trying to add an alpha " " to a numeric field.

What type of table are you updating? Can you add nulls to the column?

Here is a link to the documentation for
iWay Integration Suite

Thank your for participating in the Focal Point Forum,

Tamra Colangelo
Focal Point Moderator
Information Builders


WebFOCUS 8x - BI Portal, Developer Studio, App Studio, Excel, PDF, Active Formats and HTML5