Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  iWay Software Product Forum on Focal Point    [CLOSED] My first Iway project - quits after 1 hour
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] My first Iway project - quits after 1 hour
 Login/Join
 
Guru
posted
Sorry about the re-post, but I forgot to turn on the notifications the first time.


OK, I've got my Iway channel built and running. It's great. My only problem left is that it quits after running for 1 hour. I'm dropping a text file into a folder, and my process flow takes that and loads the records into an old mainframe DB2 database. After insering the records for an hour, it quits with a 'timeout' error. I've verified that when publishing the process flow I have zero in the timeout value, and in my file listener my execution time limit is 7200 (2 hours). Still quitting after 1 hour. Is there another parameter somewhere that I've missed? Thanks for a great forum.

Mike

This message has been edited. Last edited by: Mike in DeLand,


Webfocus 8
Windows, Linux
 
Posts: 247 | Location: Palm Coast, FL | Registered: February 05, 2010Reply With QuoteReport This Post
Member
posted Hide Post
If you're using the SQL agent, it has a timeout parameter too.


iWay Service Manager (6.0.1 - patch.62627)
DMC Version 7 Release 7
 
Posts: 12 | Registered: January 24, 2011Reply With QuoteReport This Post
Guru
posted Hide Post
Thanks for your response. In my SQL object in the designer, I do have timeout = 0 on there. I looked at the ODBC that is being used and did not see anywhere that a 1 hour timeout would be set.


Webfocus 8
Windows, Linux
 
Posts: 247 | Location: Palm Coast, FL | Registered: February 05, 2010Reply With QuoteReport This Post
Gold member
posted Hide Post
Hi Mike,
Are you using a persistent database connection?
What is the actual error message you're getting in the iWay log?
I've seen this happen where the firewall chops the connection to the MF after a period, may be worth checking with your firewall guys.


iWay 5.5 SMSP1 and 6.0.1 on Intel/Linux
 
Posts: 59 | Location: Birmingham, Blighty | Registered: October 30, 2007Reply With QuoteReport This Post
Guru
posted Hide Post
Thanks for the tip. I ran my procedure yesterday and it ran all the way through. I'm thinking maybe I didn't compile something right.


Webfocus 8
Windows, Linux
 
Posts: 247 | Location: Palm Coast, FL | Registered: February 05, 2010Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  iWay Software Product Forum on Focal Point    [CLOSED] My first Iway project - quits after 1 hour

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.