Focal Point
Flow stays in deferred status after finished

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/1381057331/m/5731049961

May 30, 2006, 01:53 PM
Jim Dale
Flow stays in deferred status after finished
I'm using 5.33 Data Migrator.

I have an RPC that get's kicked off during a flow. The rpc looks for missing records in a table. If it finds any missing records, it builds a focus table and then executes a flow to load them.

It works, the table gets updated but the flow remains in deferred status in Data Migrator Server.

Any help is appreciated.

Jim
June 09, 2006, 01:44 PM
Jim Dale
Description of problem: I was executing an ETL flow from a fex using CMASAP.
The ETL flow was executing properly but was staying in the deferred list for hours. Called IBI and worked with Michelle Griffin. Michelle had me place the following at the end of the CMASAP statement in red:

EX CMASAP REQ_NAME=300_product_map_dimension ,CM_ASYNC=OFF

CM_ASYNC=OFF causes the ETL flow to bypass the deferred list and execute immediately.

In addition, we went into Listeners (right under Workspace) and noticed that the Scheduler was crashed. We think this was the problem. After testing CM_ASYNC=OFF, I started the Scheduler by left clicking on SCHEDULER and clicking start. I went back and checked that agent in deferred list and it was gone. I tested the fex without the CM_ASYNC=OFF and it worked fine. The flow went to deferred list, then executed, then left the deferred list.

Hi Jim,
I ran this issue by Product Management. As it turns out the Scheduler is what writes the data to the log file (if running deferred) so this is expected behavior if it crashes. Regards, Michelle.