Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Go
New
Search
Notify
Tools
Reply
  
Crashed Agents
 Login/Join
 
Member
posted
One of our developers is having a problem with an ETL Flow crashing after it has been running succesfully for a couple of weeks. Myself or IBI cannot find anything wrong with it. I re-wrote the ETL from scratch and it runs fine.

Can anyone shed any light on crashed agents. The only times I've had a crashed agent is when I tried copying an ETL flow from one UNIX box to another and a crashed agent when the log file filled up.

I've searched IBI's web site and haven't been able to find causes of Crashed Agents.

Thanks,
Jim
 
Posts: 12 | Location: Bay Area - San Francisco | Registered: January 06, 2006Reply With QuoteReport This Post
Member
posted Hide Post
WE ARE USING 5.33 WEBFOCUS ON UNIX SOLARIS
WITH ORACLE TABLES AS SOURCE AND TARGET.

JIM
 
Posts: 12 | Location: Bay Area - San Francisco | Registered: January 06, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
In my experience with crashed agents, it's usually due to something being wrong with one of the target transformations. But as to what, who knows. This has been a big gripe with me in that it just crashes and you have no idea what happened - there's no log - there's nothing. The problem could be trying to put an alpha value into a numeric field (or vice-versa), or a value too large for the field, etc. But as you said, it had been running fine and then started having problems. I too have had similar experiences with simply rebuilding flows and then they are fine. Sometimes, you can just go into the target transformations, change one, save it, then change it back, and it will work fine too. My belief is that something gets out of whack with the code, and just 'touching' something regenerates it, and whatever was wrong is good again. Frustrating? Absolutely. While I understand that sometimes obscure things like this may be hard to find, as evidenced by the fact that IBI could not find the issue for you either, but to have something error out and not give you any indication as to what went wrong is just incredible. Sorry I can't be of any more assistance other than to share with you my experiences with this too.


Data Migrator 5.3, 7.1, 7.6
WebFOCUS 7.1, 7.6, 7.7
SQL Server, Oracle, DB2
Windows
 
Posts: 126 | Registered: January 18, 2007Reply With QuoteReport This Post
Member
posted Hide Post
Thanks Jessica,

Are you using 5.33? We're getting ready to migrate from 5.33 to 7.13 and maybe that will help.

I don't seem to have problems with crashed agents anymore so I don't know what our contractor is doing to cause crashed agents. I've got many ETL flows that are 3 years old and have been modified many times with no problems.

If I find out anything I'll pass it along. IBI is trying to re-create the error. I uploaded the ETL flow and they are creating the Oracle tables.

Jim
 
Posts: 12 | Location: Bay Area - San Francisco | Registered: January 06, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
My experience with crashed agents has also been on 5.3.3, with Oracle, on a Unix Sunos. Please do post again if IBI is able to recreate your problem. I'd very much like to know what they say.


Data Migrator 5.3, 7.1, 7.6
WebFOCUS 7.1, 7.6, 7.7
SQL Server, Oracle, DB2
Windows
 
Posts: 126 | Registered: January 18, 2007Reply With QuoteReport This Post
Member
posted Hide Post
Jessica,

I'll post if IBI can recreate the problem. If you do ot hear back from me, you can contact me at jdale@sfchronicle.com.

Thanks,
Jim
 
Posts: 12 | Location: Bay Area - San Francisco | Registered: January 06, 2006Reply With QuoteReport This Post
  Powered by Social Strata  
 


Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.