Focal Point
[SOLVED] Adaptor connection using Security Explicit and AD Service Account

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/1381057331/m/7887040876

August 25, 2015, 11:17 AM
Virul Patel
[SOLVED] Adaptor connection using Security Explicit and AD Service Account
Hi,

Just curious to know.

If I want to use AD Service account while using security as Explicit in Data Migrator Adaptor

1. We are using SQL Server Instance ad Server
2. Security is Explicit (In this Case we are trying)
3. User is Active Directory Account (We know that SQL Login is working)
4. We are providing password of AD Account

Its not working,

Can anyone help. how we can do that ?

This message has been edited. Last edited by: Virul Patel,


Virul Patel
Product :
iWay Data Migrator (8.1)
WebFocus 8.1
SQL SERVER 2012
August 28, 2015, 03:17 PM
Virul Patel
Here is the Answer, I got from IBI InfoResponse

-----------------------------------------------------------------------------------------------

You cannot use Explicit SQL Server security on the adapter with a Windows id.
It may only use a SQL Server id. You would need to use trusted security on
the SQL Server adapter to use Windows authentication. In order to be
impersonated at the user level you would use OPSYS security on the
Reporting Server, otherwise impersonation will be based on the user that
started the Reporting Server service.

------------------------------------------------------------------------------------------------

Thanks, Virul


Virul Patel
Product :
iWay Data Migrator (8.1)
WebFocus 8.1
SQL SERVER 2012