Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Go
New
Search
Notify
Tools
Reply
  
Lost transform registry
 Login/Join
 
Member
posted
Hello,

I have a problem with transform registry, it not appear and we can't use any transform published before. They not appear.

When we open transform forder in iWay Designer, it appear empty and in log we receive only this error:

quote:
Problem retrieving component information from repository
org.apache.xmlbeans.XmlException: error: Unexpected end of file after null
at org.apache.xmlbeans.impl.store.Locale$SaxLoader.load(Locale.java:3467)
at org.apache.xmlbeans.impl.store.Locale.parseToXmlObject(Locale.java:1270)
at org.apache.xmlbeans.impl.store.Locale.parseToXmlObject(Locale.java:1257)
at org.apache.xmlbeans.impl.schema.SchemaTypeLoaderBase.parse(SchemaTypeLoaderBase.java:345)
at com.ibi.consolesm.xml.repository.RTransformDocument$Factory.parse(Unknown Source)
at com.ibi.consolesm.misc.RepositoryExplorer.getComponentFromInputStream(RepositoryExplorer.java:3191)
at com.ibi.consolesm.misc.RepositoryExplorer.getComponent(RepositoryExplorer.java:3063)
at com.ibi.consolesm.misc.RepositoryExplorer.getComponentsByType(RepositoryExplorer.java:2972)
at com.ibi.config.ConWSContainer.getDefinesFromRepo(ConWSContainer.java:2365)
at com.ibi.config.ConWSContainer.getComponents(ConWSContainer.java:464)
at com.ibi.config.XDConWSGetConfiguration.process(XDConWSGetConfiguration.java:109)
at com.ibi.edaqm.XDConsole55Master$Worker.serviceWSCall(XDConsole55Master.java:1063)
at com.ibi.edaqm.XDConsole55Master$Worker.dispatchRequest(XDConsole55Master.java:805)
at com.ibi.edaqm.XDConsole55Master$Worker.run(XDConsole55Master.java:487)
at java.lang.Thread.run(Thread.java:801)
Caused by: org.xml.sax.SAXParseException: Unexpected end of file after null
at org.apache.xmlbeans.impl.piccolo.xml.Piccolo.reportFatalError(Piccolo.java:1038)
at org.apache.xmlbeans.impl.piccolo.xml.Piccolo.parse(Piccolo.java:723)
at org.apache.xmlbeans.impl.store.Locale$SaxLoader.load(Locale.java:3435)
... 14 more


Any ideas how to fix it?


Thanks
Manu


iWay 5.5 SM
 
Posts: 4 | Registered: June 23, 2008Reply With QuoteReport This Post
Member
posted Hide Post
Hi Manu,

This is due to that you've a 0 bytes file under the transforms folder on the server. Remove it and you'll be able to list them again.

Kind regards
 
Posts: 2 | Registered: July 31, 2008Reply With QuoteReport This Post
Member
posted Hide Post
Thanks Moko. It's that, a 0 bytes file in transformer directory.


iWay 5.5 SM
 
Posts: 4 | Registered: June 23, 2008Reply With QuoteReport This Post
  Powered by Social Strata  
 


Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.