Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  iWay Software Product Forum on Focal Point    [SOLVED] IWay write to DB2 failing
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] IWay write to DB2 failing
 Login/Join
 
Master
posted
I have a Hub-Sub setup for DB2 on MVS. I have a Data Migrator flow which selects records from DB2, joins them to a local SQL*Server table, and then writes the records back to DB2 with changes.

The Problem -- DB2 crashes the run after performing a small number of updates. Not a dependable number, sometimes the first record crashes it, sometimes the 400th. But it never runs to completion short of me requesting an exceptionally small set of records. It seems to be based on the record itself, some records jamming the system consistently while others sail through.

When I set the Commit number to a small number, say 10, when the run is in a position to run the next 50 records successfully, the job hangs at 10 records, updating the first ten but never going back to update more, and never returning control of DMC to me.

My INSERTSIZE is set to 1, my FASTLOAD is currently set off, but doesn't seem to have any effect.

I opened a ticket but it became very complicated to get IBI the information they needed to proceed and I have about a dozen other fires burning.

Has anybody seen anything like this before?

This message has been edited. Last edited by: Tamra,



 
Posts: 913 | Location: At the Mast | Registered: May 17, 2007Reply With QuoteReport This Post
Guru
posted Hide Post
While a sub-server is fine as a source we don't recommend using SUFFIX=EDA as a target, especially not for large data volumes. If you were to run a DataMigrator server on MVS you will also get better throughput.
 
Posts: 379 | Location: New York City | Registered: May 03, 2007Reply With QuoteReport This Post
Master
posted Hide Post
We had SUFFIX=DB2 prior to this (SET SQLENGINE=DB2 in the MVS iWay profile) with the same result. It seems that there are certain records that stop the run, regardless of whether they're the first encountered or the 500th. You get to them, it crashes. Very odd behavior. I can't figure out what is different about these records.

I don't need fast, as this is a one-time remediation of data. But I do need dependable.

And I don't get the option to create a new flow on the MVS iWay service. So I'll leap to the conclusion that feature is not installed.



 
Posts: 913 | Location: At the Mast | Registered: May 17, 2007Reply With QuoteReport This Post
Guru
posted Hide Post
But still running the DM serer on Windows, not on the IBM mainframe?

But if the same records always fail and do so regardless of the adapter, then there must be something about them. Please upload them to the hottrack case so the hotline staff can try to reproduce your problem.
 
Posts: 379 | Location: New York City | Registered: May 03, 2007Reply With QuoteReport This Post
Master
posted Hide Post
I set up a StarSQL connection via ODBC. That seems to run without a hitch, so it may end up being the bootstrap solution for the problem.



 
Posts: 913 | Location: At the Mast | Registered: May 17, 2007Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  iWay Software Product Forum on Focal Point    [SOLVED] IWay write to DB2 failing

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.