Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  iWay Software Product Forum on Focal Point    Data Flow not recognizing global variable
Go
New
Search
Notify
Tools
Reply
  
Data Flow not recognizing global variable
 Login/Join
 
Silver Member
posted
A Data Flow (ETL process) is not recognizing a global variable.

I’m running the following fex:

-****************************************************
EX DATE_ROUTINES/calc_7_days_prior
-RUN

-TYPE &&LSTMONDAY &&SUNDAY

EX CMASAP REQ_NAME=040_update_work_wod
-RUN

-EXIT
-****************************************************


When 040_update_work_wod runs, it abends with the error below. I’m using the global variable &&LSTMONDAY in the filter of 040_update_work_wod Data Flow.

Submitted for deferred
Request - 040_update_work_wod (Owner: eda) submitted.
work_wod type Oracle Existing target
Issuing PREPARE
0 ERROR AT OR NEAR LINE 143 IN PROCEDURE 040_updaFOCEXEC *
(FOC295) A VALUE IS MISSING FOR: &LSTMONDAY
Output retrieved
Elapsed run time 0:00:00

If I place DATE_ROUTINES/calc_7_days_prior as an rpc within the 040_update_work_wod right before the Data Flow, it works OK.

Any hlp is most appreciated.
Thanks,
Jim
 
Posts: 43 | Location: San Jose, California. | Registered: July 18, 2005Reply With QuoteReport This Post
Silver Member
posted Hide Post
I found where you have to place PARM after the
CMASAP statement like:

EX CMASAP REQ_NAME=040_update_work_wod,PARMS="&&MON=&&LSTMONDAY"

This doesn't seem to work, so my question is
how can you set a parm to equal a parm on the CMASAP statement???
 
Posts: 43 | Location: San Jose, California. | Registered: July 18, 2005Reply With QuoteReport This Post
Silver Member
posted Hide Post
After talking with IBI, they said you cannot pass parameters to a workflow on version 5.33.
Version 7.1 will allow parameters to be passed to a work flow.
 
Posts: 43 | Location: San Jose, California. | Registered: July 18, 2005Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Jim,

I can confirm that you can pass parameters at 7.1 . We are doint it right now.


WF7.1.4 Prod/Test, MRE, self serve, DM
 
Posts: 176 | Location: Desplaines | Registered: August 05, 2004Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Jim, are you sure that IBI told you this. I have two different instances where I am setting global variables for use in process flows and it works fine. I am using 5.3.3.

Ken


Prod - WF 7.6.4 Unix/Solaris - Self-Service, BI Dashboard, MRE
Dev - WF 7.6.4 Unix/Solaris - Self-Service, BI Dashboard, MRE
Databases: Oracle 10g, SQL Server 2000, DB2.
 
Posts: 177 | Location: Calgary, Alberta, Canada | Registered: April 25, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  iWay Software Product Forum on Focal Point    Data Flow not recognizing global variable

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.