Focal Point
[SOLVED] Time Stamp Java Error

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/1381057331/m/9997016986

March 14, 2018, 11:45 AM
srajeevan
[SOLVED] Time Stamp Java Error
Hi,

When i check my scheduled flow logs.i see some java errors for some input files.
"java.lang.illegalargumentexception: timestamp format must be yyyy-mm-dd hh:mm:ss[.fffffffff] in java"

I have checked my Date fields in the target synonym and the sql target table.
Infact i did recreate DBMS table operation on synonym to get the same datatype in sql table as well.

I have not idea what this error means.?I am loosing rows in eevry flow becuase of this error.Any one encountered this error.?

This message has been edited. Last edited by: FP Mod Chuck,


WF8202M,Windows 7,8,10
HTM,PDF,EXCEL
March 16, 2018, 01:13 PM
FP Mod Chuck
srajeevan

Please post how the date fields are defined in the master file for the source and target tables.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
March 17, 2018, 10:39 PM
vinodh
hi srajeevan,

it could be data format mismatch error.

the data that is trying to get inserted is not in the format expected by the field.

regards
Vinodh.R


WebFOCUS 8
Windows, All Outputs
March 20, 2018, 01:32 PM
srajeevan
got it working.
there was empty strings in one date field like vinodh mentioned and this caused the issue.
Inserted transformation for the date field and passed default date value 1900-01-01 for those empty string.
Thanks.


WF8202M,Windows 7,8,10
HTM,PDF,EXCEL