Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  Performance Management Framework (PMF)    [SOLVED] "&" gives error while creating Objective
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] "&" gives error while creating Objective
 Login/Join
 
<ABHINAV BALI>
posted
Hi,

I am using 5.2.1. When we name an objective with & in between, say for example my objective name is "This & That",save the objective and then press link measures button, it gives error

0 ERROR AT OR NEAR LINE 56 IN PROCEDURE _PMF_PM_MEAS_SRC_O
(FOC261) EXPRESSION IS INCOMPLETE BECAUSE AN OPERATION IS MISSING


If I remove "&", it works fine.

Is "&" not allowed while naming objective.

Thanks
Abhinav

This message has been edited. Last edited by: <ABHINAV BALI>,
 
Reply With QuoteReport This Post
Master
posted Hide Post
Correct. You must escape it like this: "This &| That". Look into the Edit function to help you do this programmatically.


------------------------------------
WF Environment:
------------------------------------
Server/Client, ReportCaster, Dev Studio: 7.6.11
Resource Analyzer, Resource Governor, Library, Maintain, InfoAssist
OS: Windows Server 2003
Application/Web Server: Tomcat 5.5.25
Java: JDK 1.6.0_03
Authentication: LDAP, MRREALM Driver
Output: PDF, EXL2K, HTM

------------------------------------
Databases:
------------------------------------
Oracle 10g
DB2 (AS/400)
MSSQL Server 2005
Access/FoxPro
 
Posts: 561 | Registered: February 03, 2010Reply With QuoteReport This Post
Master
posted Hide Post
We tried the &| and it still causes an issue.

Fundamentally in 5.2.1 you're still limited in not being able to use a number of characters that are protected to WebFOCUS code. It's definitely an annoyance. Other characters that will cause issues are percent sign (%), period (.), comma (,), and semicolon (Wink. You'll have this problem trying to use these in names, and it's documented to avoid them for the time being.

Ultimately we'll come up with a way to allow this but that way is not already built in 5.2.1.

thanks


Bob Jude Ferrante
Director of Business and Development
WebFOCUS Performance Management
Bob_Ferrante@ibi.com
917-339-5105

I'll take any questions about PMF - business or technical - anytime!

 
Posts: 919 | Registered: March 26, 2003Reply With QuoteReport This Post
Master
posted Hide Post
Thanks for the info Bob. I actually realized after replying that this was the PMF forum and not the WF forum.

For my own curiosity, are there any workarounds such as using the html style equivalents (i.e. & a m p ; - w/o the spaces) or passing the ASCII code via something like the CTRAN() function?


------------------------------------
WF Environment:
------------------------------------
Server/Client, ReportCaster, Dev Studio: 7.6.11
Resource Analyzer, Resource Governor, Library, Maintain, InfoAssist
OS: Windows Server 2003
Application/Web Server: Tomcat 5.5.25
Java: JDK 1.6.0_03
Authentication: LDAP, MRREALM Driver
Output: PDF, EXL2K, HTM

------------------------------------
Databases:
------------------------------------
Oracle 10g
DB2 (AS/400)
MSSQL Server 2005
Access/FoxPro
 
Posts: 561 | Registered: February 03, 2010Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  Performance Management Framework (PMF)    [SOLVED] "&" gives error while creating Objective

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.