Focal Point
[Closed] - Scorecard Security

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/1461084022/m/5977071586

January 10, 2017, 04:57 PM
Jasen
[Closed] - Scorecard Security
I am guessing that I am doing something wrong, but I can't seem to get this to work.

I went into Access Security on the Contract Services scorecard. I switched the business segment to contract services. My understanding is then that the scorecard will filter out everything that does not roll up into my contract service dimension. My tree map still shows all of my business segments however.

What am I missing?

Thanks

This message has been edited. Last edited by: Jasen,

Scorecard



WebFocus 8.002
PMF 8.2.3
Windows, all output
January 10, 2017, 05:07 PM
Bob Jude Ferrante
Access security filters the row data for Measures.

If you want this to be filtered by the Scorecard and not by each user's private filters, is it a correct assumption that you configured Security to 'S'?

Did you check off which measures you want to be filtered? (On each measure you want to be filtered for Dimension, please check Access Security and save.) This tells PMF to filter dimensions for that measure.

For Scorecards where you didn't set up Access security, the measure will just filter to show all.

Hope this helps!


Bob Jude Ferrante
Director of Business and Development
WebFOCUS Performance Management
Bob_Ferrante@ibi.com
917-339-5105

I'll take any questions about PMF - business or technical - anytime!

January 11, 2017, 12:52 PM
Jasen
I did miss checking the Access Security box. I still get all business segments when I open the dashboard.

I also clicked on the reset dashboards defaults button just to make sure that was not the issue as well.


WebFocus 8.002
PMF 8.2.3
Windows, all output
January 11, 2017, 01:05 PM
Bob Jude Ferrante
Jasen

Sorry, last bit, which I should have included in my last comment.

I'm assuming your logged-in Owner ID is linked to the Administration (administrato) functional role.

Note that any owner linked to the Administrator Functional Role (role ID: 'administrato') will *never* have filters applied to them. That is by design - full PMF administrators see *everything* and *never* have filters applied.

You could:
* OK approach: Try changing the role for your user to the "Administrator with Access Security" role.
* Best approach: create a new separate owner ID you can use to test access security, and link THAT owner either to a security-active role or to "Administrator with access security". Please make sure that this new Owner also has that Scorecard included in its list of Scorecards.

I think this will nail the problem.

Hope this helps!
thanks for your patience.


Bob Jude Ferrante
Director of Business and Development
WebFOCUS Performance Management
Bob_Ferrante@ibi.com
917-339-5105

I'll take any questions about PMF - business or technical - anytime!

January 11, 2017, 02:11 PM
Jasen
You were correct on all fronts except that it still doesn't work.

I was using my ID so that made since and once I read it I remembered that in the training.

So, I had one of my analysts try opening the dashboard. Same problem he could still see all the business segments. He has a functional role of analyst.

Any other ideas?


WebFocus 8.002
PMF 8.2.3
Windows, all output
January 12, 2017, 08:44 PM
Jasen
After testing with a different user, it was discovered that it was filtering. The above steps fixed the issue.


WebFocus 8.002
PMF 8.2.3
Windows, all output