Focal Point
Error S01O_B in pmf_form_security_get_object_ownership

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/1461084022/m/6807053716

March 02, 2012, 08:59 AM
dcorp
Error S01O_B in pmf_form_security_get_object_ownership
I am looking for insight as to what is causing this error to occur: (Error S01O_B in pmf_form_security_get_object_ownership) I have a dashboard created within PMF that opens with no problem in the Today Page for those users I have given access, but produces the S01SO_B error when the same user attempts to run the dashboard from the Analytics page. The dashboard is associated to a scorecard and I have granted the user access to the scorecard. It appears that a gadget is causing the error to occur. Are there other security settings that I need to address? Note: The dashboard is a combination of the dimension gadget within PMF and some created gadgets. The dashboard and gadgets were created by the administrator and the users receiving the error are Author's and Analyst's. Thanks in advance for insight provided.


WebFOCUS 8.1.05/PMF 8.1.4,Tomcat,IIS,Windows/iseries,sql server 2008,Excel/ PDF/HTML
March 02, 2012, 09:04 AM
dcorp
I neglected to mention that the dashboard is a public dashboard.


WebFOCUS 8.1.05/PMF 8.1.4,Tomcat,IIS,Windows/iseries,sql server 2008,Excel/ PDF/HTML
March 02, 2012, 09:07 AM
Bob Jude Ferrante
Try doing a View Source on that very web page where you're getting the error.

Note: Associating content with Scorecards is a 5.3 feature, and 5.3 isn't generally available yet. Therefore, we assume this was given to you by a consultant as a customization. We recommend you check with the consultant to assist you in debugging this error.


Bob Jude Ferrante
Director of Business and Development
WebFOCUS Performance Management
Bob_Ferrante@ibi.com
917-339-5105

I'll take any questions about PMF - business or technical - anytime!

March 02, 2012, 09:10 AM
Bob Jude Ferrante
I don't think that makes a difference. Previous comment still pertains.

thanks!


Bob Jude Ferrante
Director of Business and Development
WebFOCUS Performance Management
Bob_Ferrante@ibi.com
917-339-5105

I'll take any questions about PMF - business or technical - anytime!

March 02, 2012, 06:04 PM
dcorp
I was able to resolve this issue. It appears that the Gadgets & Dashboard Designs functional role settings for Analyst and Author were the cause of of the problem. Analyst was set to Admin(if owner) else Viewer and Author was set to Admin(if owner) else Editor. I changed both to Viewer and the dashboard now displays correctly.


WebFOCUS 8.1.05/PMF 8.1.4,Tomcat,IIS,Windows/iseries,sql server 2008,Excel/ PDF/HTML