Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  Performance Management Framework (PMF)    [Closed] - Tree Map Incorrect Color
Go
New
Search
Notify
Tools
Reply
  
[Closed] - Tree Map Incorrect Color
 Login/Join
 
Gold member
posted
I have a tree map that is green in color for a business segment. I believe it should be yellow.
When I look at the detail behind the graph it says that my percent of target reached is 382% even though the attachment says it is 96%. Has anyone else ran into this issue?

This message has been edited. Last edited by: Trevor Dunn,


WebFocus 8.002
PMF 8.2.3
Windows, all output


PDF DocTree_Graph.pdf (20 Kb, 18 downloads)
 
Posts: 72 | Location: Minnesota | Registered: December 28, 2012Reply With QuoteReport This Post
Master
posted Hide Post
The "grid behind the chart" total doesn't look right.

Somehow it's not using our common math for calculating percent reached for actual v. target.

We'll take a look at that... thanks for finding it!


Bob Jude Ferrante
Director of Business and Development
WebFOCUS Performance Management
Bob_Ferrante@ibi.com
917-339-5105

I'll take any questions about PMF - business or technical - anytime!

 
Posts: 916 | Registered: March 26, 2003Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Jasen - Could you please try this:

Go to the Manage Tab, Gadgets, and open HTML 5 Metric Tree Map. Then

1) If you see a Group By Time, remove that. You should only have the single Group By: 'User Specified Dimension'
2) Next, under Filters, set the Time to Current Period (or whatever period you want to report on)
3) Save
4) Click the Reset Dashboard defaults button

Then go back to your Dashboard and do a browser refresh.

Eric

 
Posts: 164 | Registered: March 26, 2003Reply With QuoteReport This Post
Gold member
posted Hide Post
Nothing changed when I did that. The colors are still incorrect and the data is still adding.


WebFocus 8.002
PMF 8.2.3
Windows, all output
 
Posts: 72 | Location: Minnesota | Registered: December 28, 2012Reply With QuoteReport This Post
Master
posted Hide Post
Step #4 -- clicking the Reset Dashboard Defaults button -- applies the setting to all dashboards that use the gadget. If that step doesn't happen, you won't notice anything unless you drag the gadget onto another dashboard.

Did you do that step?


Bob Jude Ferrante
Director of Business and Development
WebFOCUS Performance Management
Bob_Ferrante@ibi.com
917-339-5105

I'll take any questions about PMF - business or technical - anytime!

 
Posts: 916 | Registered: March 26, 2003Reply With QuoteReport This Post
Gold member
posted Hide Post
Yes, I verified it again. I still have a green tree map color even though when I right click it is 97.1 % which is yellow.


WebFocus 8.002
PMF 8.2.3
Windows, all output
 
Posts: 72 | Location: Minnesota | Registered: December 28, 2012Reply With QuoteReport This Post
Master
posted Hide Post
I can see what's happening. If you look at the grid behind the tree map, it's evaluating (correctly) the single period you selected in the time dropdown on the right, whereas the drill is passing only the time range and not the period.

We're already working on that one, so good thing. Sorry you bumped into it.

thanks


Bob Jude Ferrante
Director of Business and Development
WebFOCUS Performance Management
Bob_Ferrante@ibi.com
917-339-5105

I'll take any questions about PMF - business or technical - anytime!

 
Posts: 916 | Registered: March 26, 2003Reply With QuoteReport This Post
Gold member
posted Hide Post
I am still getting incorrect colors on the tree map when I have a filter set to Previous 12 months for time. The right click on the left shows the colors of the tree map I would expect to see when I drill into the next level of the map. I get all green values as you can see on the middle graph. When I flip the chart to see the detail behind the chart the % reached are incorrect and appear to be adding the twelve months.

As my signature did not update, we are now using PMF 8.2.2


WebFocus 8.002
PMF 8.2.3
Windows, all output


 
Posts: 72 | Location: Minnesota | Registered: December 28, 2012Reply With QuoteReport This Post
Member
posted Hide Post
Do the colors become incorrect and the flipped grid's percentages become summed only after the filter is applied?

Thank you for bringing this to our attention.


Trevor Dunn
Information Builders
 
Posts: 12 | Registered: April 13, 2017Reply With QuoteReport This Post
Gold member
posted Hide Post
I am not filtering on anything. I have the gadget set to display as PREV_YYYY in the settings. It is summing the percentages from the minute that the gadget is displayed.


WebFocus 8.002
PMF 8.2.3
Windows, all output
 
Posts: 72 | Location: Minnesota | Registered: December 28, 2012Reply With QuoteReport This Post
Member
posted Hide Post
We are currently addressing this, but there may be something you can do to the Tree Map gadget on your end. I know Eric had said earlier to remove Time as a grouping, but you might try adding it back on. The percentage summation error is linked to how particular gadgets handle time. In this case, I suspect that the incorrect colors come from this as well - the wrong values being summed.

Please let me know what you find, and if both behaviors persist, feel free to post here or send me an email with a snapshot attached (if you'd like).


Trevor Dunn
Information Builders
 
Posts: 12 | Registered: April 13, 2017Reply With QuoteReport This Post
Gold member
posted Hide Post
I seem to have found another issue with the tree map. The colors are not matching up when I filter. When I am looking at a division as a whole (rail grinding) RG410 is red. When I drill into a sub division (Series 400) it turns green. The color should be green. The data table when I flip the chart even has the same values (111.2%).

This message has been edited. Last edited by: Jasen,


WebFocus 8.002
PMF 8.2.3
Windows, all output


 
Posts: 72 | Location: Minnesota | Registered: December 28, 2012Reply With QuoteReport This Post
Gold member
posted Hide Post
A case has been opened.


WebFocus 8.002
PMF 8.2.3
Windows, all output
 
Posts: 72 | Location: Minnesota | Registered: December 28, 2012Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  Performance Management Framework (PMF)    [Closed] - Tree Map Incorrect Color

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.