Focal Point
[resolved] Loading Measures outside the GUI

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/1461084022/m/9647082716

February 29, 2012, 03:34 PM
Moogle
[resolved] Loading Measures outside the GUI
Hi Team,

There is a file in mainstreet called: pmf_meas_ldr_load_batch_tmplt.fex

This utility exists to load measures outside of the PMF GUI, and I've used it at a previous client, but now I am running into an issue.

I copied the file into pmf_custom, renamed it to something meaningful to my client, added all my measure_series ids to the list and ran it from within Dev Studio. The first 10 to 15 measures worked fine, but then the screen pops up with this message and the load stops:

Reporting Server messages exceeded IBIF_max_messages, report retrieval aborted.


I thought it might be a problem with a specific measure load, so I did a test where I loaded the same measure again and again. It completes about 15 cycles and then stops, and the translog.log gets to be about 11 KB in size; the log shows 15 complete runs and then the start of a 16th run.

With WebFOCUS, when I see the above message, it is often because I'm echoing my code and it becomes too large for the server to handle. To solve that, I will include this SET, which stops the collection of the code during execution, thus preventing the message from happening:

-SET &ECHO = OFF ;


Unfortunately, I included the SET, but it did not seem to make any difference in this situation.

How do I solve this, please?

Cheers,

Joey

This message has been edited. Last edited by: Moogle,


-WebFOCUS 8.2.01 on Windows
February 29, 2012, 03:42 PM
Bob Jude Ferrante
Max messages is a WebFOCUS Client setting.

Go to WebFOCUS Administration Console, Configuration, General, set IBIF_max_messages to -1 to make it infinite. The default is pretty low - 20K lines of tracing, barely enough to run even a simple FOCEXEC if you have set ECHO=ALL.

B


Bob Jude Ferrante
Director of Business and Development
WebFOCUS Performance Management
Bob_Ferrante@ibi.com
917-339-5105

I'll take any questions about PMF - business or technical - anytime!

February 29, 2012, 04:34 PM
Moogle
Hi Bob,

I set the IBIF_max_messages to -1, and I no longer get that error.

I loaded about 50 measures and then received this:
 
Reporting server exceeeded connection limit.
Please investigate reporting server log for: EDASERVE 


I know where that setting lives, so I'm going to experiment with various options to get past this error.

Cheers,

Joey
February 29, 2012, 04:53 PM
Moogle
On the reporting server, I clicked Workspace | Configuration Files | Workspace - edaserve.cfg

I changed this:
SERVICE = DEFAULT
BEGIN
  maximum = 50
  number_ready = 10
  idle_session_limit = 10
  idle_agent_limit = 10
  agent_refresh = 1
  connection_limit = 120
END


To this:
SERVICE = DEFAULT
BEGIN
  maximum = 50
  number_ready = 10
  idle_session_limit = 10
  idle_agent_limit = 10
  agent_refresh = 1
  connection_limit = 250
END


End result is that I loaded 88 measures in about three minutes. If I'd done it through the GUI, it would have taken about an hour's worth of clicks.

Thank you, Bob, and have a great rest of your day.

Cheers,

Joey