Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] What is the max lines allowed in a fex?

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] What is the max lines allowed in a fex?
 Login/Join
 
Member
posted
Created a fex that has 752 lines - cannot save it into MRE. When I give this fex a name and click o.k. the save diag. box goes away but the fex does not get saved to MRE. Just for the heck of it I deleted 50 lines and tried to save it and it saved just fine????? Ideas anyone?????


Webfocus 7.6.8
Windows Server 2003/IIS/Tomcat/Oracle10g

This message has been edited. Last edited by: Kerry,
 
Posts: 14 | Registered: November 05, 2008Report This Post
Member
posted Hide Post
Forgot to mention it has mutltiple -includes...not sure if there is a limit to that or not?
 
Posts: 14 | Registered: November 05, 2008Report This Post
Virtuoso
posted Hide Post
As far as I know, there is not a limit to the number of lines allowed. We have a few that are even larger than yours and haven't had any issues. I have seen the content of some lines cause the fex to not save, but never really figured out why. Examine the contents of those last 50 lines and see if there is anything strange. You might try cutting them from the fex and posting them into notepad to see if any odd characters appear and then re-pasting back into you DS fex editor. Also (assuming this in NOT a disk space issue) you might want to check and see if there are space restrictions or file size quotas at the OS level.


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Report This Post
Expert
posted Hide Post
Although it is in 7.1 on Unix, I have a fex in MRe that is over 3000 lines.

Could this be OS related ?

You may have to talk to IBI Tech Support about this.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Platinum Member
posted Hide Post
I've worked with many fex containing 1000 lines of code and never had a problem saving.

I agree with Darrin Lee, look for something strange, a non printable character perhaps, in the text.

If it's not obvious, reduce the fex to the absolute minimum to make it syntactally correct, say a single field with no filtering for RECORDLIMIT EQ 5. If that works, add stuff back in bit by bit, saving after each addition, until it fails to save. Then you know the last bit you added contains the bad stuff. Remove the last addition and add only half of it back in and save. By iterations of adding smaller and smaller 'halves' you'll find the exact line containing the code that causes the failure.


WIN/2K running WF 7.6.4
Development via DevStudio 7.6.4, MRE, TextEditor.
Data is Oracle, MS-SQL.
 
Posts: 154 | Location: NY | Registered: October 27, 2005Report This Post
Master
posted Hide Post
I had this happen once before. What we found was a line that was supposed to be a -* was just a -.


In FOCUS since 1985. Prod WF 8.0.08 (z90/Suse Linux) DB (Oracle 11g), Self Serv, Report Caster, WebServer Intel/Linux.
 
Posts: 975 | Location: Oklahoma City | Registered: October 27, 2006Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] What is the max lines allowed in a fex?

Copyright © 1996-2020 Information Builders