Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Go
New
Search
Notify
Tools
Reply
  
styles
 Login/Join
 
Member
posted
I have seen some discussion about this but :
we are using devstudio on windows and server/wf client code is installed on remote machine where all code is maintained. According some answers, the default style like DEFLT can be found on the devstudio part.
But we are not using this. When we use report painter we always get a message that the deflt.sty can not be found. Because it is looking for this at the server machine. The styles are located in a specific subdirectory of wf client code. There is some recommendation to copy the sty files to the APP PATH
What is meant by APP PATH and how can this be defined/located
we tried to copy the sty to APPROOT, without success.
Any hint to find this setting or how todo this with sty files is accepted
Thanks for all update
Best Regards, Guy Przytula


Thanks for all update/help
Best Regards, Guy Przytula

====================
Wf server/rcaster 765 on Linux390 - Wf studio on Windows XP
 
Posts: 16 | Registered: July 01, 2008Reply With QuoteReport This Post
Virtuoso
posted Hide Post
APP PATH is the folder your Masters or Fexs are Located assciated with what you are using. You could try putting it in the baseapp folder to be used by all.


In Focus since 1993. WebFOCUS 7.7.03 Win 2003
 
Posts: 1903 | Location: San Antonio | Registered: February 28, 2005Reply With QuoteReport This Post
Member
posted Hide Post
thanks for the update
that was tested, but only applies for run
the server will look for files in folders specified by app path
but we are developing with studio and this process is looking at another location on the server ?? also not locally, because these sty files exist locally on the studio machine.
we are developing procedures and using files, located at server location
best regards, guy przytula


Thanks for all update/help
Best Regards, Guy Przytula

====================
Wf server/rcaster 765 on Linux390 - Wf studio on Windows XP
 
Posts: 16 | Registered: July 01, 2008Reply With QuoteReport This Post
Expert
posted Hide Post
Are you developing in Projects or Data Servers?

Projects writes to the approot on the WebFOCUS Client. Data Servers writes to the approot on the Reporting Server. Depending on what you are actually doing, the style files may have to be in both places.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Reply With QuoteReport This Post
Member
posted Hide Post
thanks for the update
but client and server code is installed on same machine and approot is defined for both installation at same path
we have tried to copy the deflt.sty below the application folder below approot and in that case it is ok. it means we have to copy the styles below each application group and repeat this after creating a new application group


Thanks for all update/help
Best Regards, Guy Przytula

====================
Wf server/rcaster 765 on Linux390 - Wf studio on Windows XP
 
Posts: 16 | Registered: July 01, 2008Reply With QuoteReport This Post
Expert
posted Hide Post
quote:
because these sty files exist locally on the studio machine.


The style files need to be in ibi/apps on the server not on the desktop. And as Prarie mentioned, you can put them in a directory that is available to everyone. Put the directory name in the APP PATH in edasprof.prf.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Reply With QuoteReport This Post
Member
posted Hide Post
thanks for the update
the files are on the server and in a directory specified in app path (eg baseapp)
this does not work. the only way to resolve is to copy the files to the directory (=name of application group) and it is corrected. the files have been placed also in other application group and that does not help, only the current application group folder. this means if you have 20 groups, you need to copy the files 20 times


Thanks for all update/help
Best Regards, Guy Przytula

====================
Wf server/rcaster 765 on Linux390 - Wf studio on Windows XP
 
Posts: 16 | Registered: July 01, 2008Reply With QuoteReport This Post
Expert
posted Hide Post
All of the styles that come with WebFOCUS are stored here:

/WebFOCUS/ibi/webfocus76n/ibi_html/template

If you are on Windows (BTW, update your profile with your platform and release please), the slashes will be going the other way.

In Report Painter, if you click on Report/Styling... and click on the Style File Selection button, you will see all of the style files in the directory above.

I guess I don't understand your configuration. Is your WebFOCUS client on the same machine as the reporting server?

Are you doing localhost development in Dev Studio?

I also am working in DS with a remote WF install (on AIX) and I can see these files just fine.

Maybe if you explained your config in a little more detail, we could figure out what your problem is.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Reply With QuoteReport This Post
Member
posted Hide Post
Thanks for the update
I will explain the setup first
We have wf server and client code and rcaster installed on Linux/390 on the same box
the real client - studio is on a windows station
yes, the styles are present in the indicated directory. when opening the setting for report painter-we see all available styles, but whenever we take one (different from none) and start with report painter we get the message that we have an error in line 1 of the style...
the only way to avoid the error, is to copy the style to the application directory below approot
I hope this is more clear..


Thanks for all update/help
Best Regards, Guy Przytula

====================
Wf server/rcaster 765 on Linux390 - Wf studio on Windows XP
 
Posts: 16 | Registered: July 01, 2008Reply With QuoteReport This Post
  Powered by Social Strata  
 


Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.