Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [Solved]FOC003 THE FIELDNAME IS NOT RECOGNIZED

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[Solved]FOC003 THE FIELDNAME IS NOT RECOGNIZED
 Login/Join
 
Member
posted
We recently upgraded from WF8005M to WF8105M. I am new to WF application and I have limited knowledge. In one of our BI portals, when I run the report I am getting below error:
Your request did not return any output to display.
Possible causes:
- No data rows matched the specified selection criteria.
- Output was directed to a destination such as a file or printer.
- An error occurred during the parsing or running of the request.



0 ERROR AT OR NEAR LINE 9 IN PROCEDURE daily_interface_mtd_open_err_log
(FOC003) THE FIELDNAME IS NOT RECOGNIZED: IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.TRANS_DATE_MDYY
BYPASSING TO END OF COMMAND
(FOC009) INCOMPLETE REQUEST STATEMENT

In content tree- >Reporting server - >edaserve ->edwmain I can see the access file with file name IA_MQSI_ERROR_ANALYSIS_WFV.acx but I don't see master file showing name as IA_MQSI_ERROR_ANALYSIS_WFV.mas. The name of the file that is displaying in content tree is MQSI Interface Error (Title) which has name as IA_MQSI_ERROR_ANALYSIS_WFV.mas. (When I hover over the file I can see the file name)

When I go to reporting server though Admin console under application directories -> edwmain I can see master file named IA_MQSI_ERROR_ANALYSIS_WFV.mas (icon image looks different - shows a link with master file image/icon) .

Please help me or provide some guidance on how I can resolve the problem.

Fex code for daily_interface_mtd_open_err_log.fex:

SET LINES = 9999
-SET &MTD_FILTER=EDIT(DATECVT(DATEADD('&YYMD','D',0),'YYMD','A8YYMD'),'999999');

DEFINE FILE IA_MQSI_ERROR_ANALYSIS_WFV
TRANS_DATE_MDYY/MDYY=HDATE( IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.TRANS_DT,'MDYY');
TRANS_YEARMONTH/A6=EDIT(DATECVT(HDATE( IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.TRANS_DT,'YYMD'),'YYMD','A8YYMD'),'999999');
END
TABLE FILE IA_MQSI_ERROR_ANALYSIS_WFV
BY IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.TRANS_DATE_MDYY AS 'Date'
BY IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.ORDER_N AS 'Order No'
BY IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.TRANS_ID AS 'Transaction ID'
BY IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.TRANS_TY_CD AS 'Trx Error'
BY IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.TRANS_TY_NM AS 'Trx Description'
BY IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.ERROR_N AS 'Error No'
BY IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.ERROR_TX AS 'Error Text'
ON TABLE SUBHEAD
"MTD Open Errors Log"
WHERE ( IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.TRANS_TY_RESP_CD EQ 'ERR' );
WHERE ( IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.TRANS_YEARMONTH EQ '&MTD_FILTER' );
WHERE ( IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.CLIENT_ID EQ 'TTOM' );
ON TABLE SET EMPTYREPORT ON
ON TABLE SET HTMLEMBEDIMG ON
ON TABLE SET PAGE-NUM NOLEAD
ON TABLE SET BYDISPLAY ON
ON TABLE SET ASNAMES ON
ON TABLE NOTOTAL
ON TABLE PCHOLD AS MTD_ERR_LOG FORMAT &WFFMT.EVAL
ON TABLE SET HTMLCSS ON
ON TABLE SET STYLE *
INCLUDE = IBFS:/EDA/EDASERVE/_EDAHOME/ETC/endeflt.sty,
$
PAGESIZE='Legal',
ORIENTATION=LANDSCAPE,
SUMMARY='MTD_ERR_LOG',
TITLETEXT='MTD_ERR_LOG',
$
TYPE=REPORT,
COLUMN=N7,
WRAP=6.000000,
$
ENDSTYLE
END


Thanks

This message has been edited. Last edited by: RamyaKalyan,


8.0.05 & 8.1.05
 
Posts: 12 | Registered: September 27, 2016Report This Post
Gold member
posted Hide Post
It might have something to do with DEFINE. Open in GUI and check under what segment is 'TRANS_DATE_MDYY' field being created.

You could also try removing IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT. in LINE 9 and just keep
BY TRANS_DATE_MDYY AS 'Date'


Tharun Katanguru
SBOX- 8205 DEV/TEST/PROD : 8105 8205
Linux, All Outputs
 
Posts: 52 | Location: BOWL OF PASTA | Registered: October 13, 2016Report This Post
Virtuoso
posted Hide Post
A variation on tomatosauce's suggestion is to write a simple report to see if you can print IA_MQSI_ERROR_ANALYSIS_WFV.USR_MQSI_ERROR_ANALYSIS_FLAT.TRANS_DATE_MDYY. If you get an error then a defined field based on this won't work either. If you don't get an error, you may have a syntax error in your define that's causing the problem. Also, make sure you don't have any other copies of IA_MQSI_ERROR_ANALYSIS_WFV.MAS in the path. Maybe there's an issue in that master file.


WebFOCUS 8206, Unix, Windows
 
Posts: 1853 | Location: New York City | Registered: December 30, 2015Report This Post
Member
posted Hide Post
Thanks tomatosauce and BabakNYC. The issue is resolved. A Join was missing in master file and we corrected it.


8.0.05 & 8.1.05
 
Posts: 12 | Registered: September 27, 2016Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [Solved]FOC003 THE FIELDNAME IS NOT RECOGNIZED

Copyright © 1996-2020 Information Builders