Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

New TIBCO Community Coming Soon
In early summer, TIBCO plans to launch a new community—with a new user experience, enhanced search, and expanded capabilities for member engagement with answers and discussions! In advance of that, the current myibi community will be retired on April 30. We will continue to provide updates here on both the retirement of myibi and the new community launch.

What You Need to Know about Our New Community
We value the wealth of knowledge and engagement shared by community members and hope the new community will continue cultivating networking, knowledge sharing, and discussion.

During the transition period, from April 20th until the new community is launched this summer, myibi users should access the TIBCO WebFOCUS page to engage.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Messages on Dashboards

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] Messages on Dashboards
 Login/Join
 
Master
posted
so we have a sql table we write status's to and have a little report we put on our dashboards. typical messages show vintage of data, if refreshes are done etc.

I'd like to do something a little different. Lets say data failed to refresh altogether. I'd like to have a message I can put on a given page saying: DATA HAS NOT BEEN REFRESHED!!!

I can do this, and I can make it a big font. Can I make it blink?

I have another one. Some dashboards simply take time to refresh. Yes WF says: Loading...

Can we have a message though that say appears after 30 second saying Refreshe still in progress.

Curious how these things might be done.

This message has been edited. Last edited by: FP Mod Chuck,


WebFOCUS 8206.08
Windows, All Outputs
 
Posts: 603 | Registered: June 28, 2013Report This Post
Master
posted Hide Post
The problem with the 'loading' is that any code you've added isn't available.

Only thing you can do is have another report on the same page access the your little report. If after a certain periode the contents are still 'loading' then replace the source code for your little report's frame.


And blinking.. make a animate GIF. Or use CCS3 transitions. You could animate the transparency between 0% and 100% ( or 25% and 100% )

G'luck,
Dave


_____________________
WF: 8.0.0.9 > going 8.2.0.5
 
Posts: 668 | Location: Veghel, The Netherlands | Registered: February 16, 2010Report This Post
Master
posted Hide Post
Thoughts on how I might measure the 30 seconds and evaluate if my data is still loading?


WebFOCUS 8206.08
Windows, All Outputs
 
Posts: 603 | Registered: June 28, 2013Report This Post
Silver Member
posted Hide Post
In your status table could you have refresh started and ended times? Maybe before displaying anything you can check if a refresh is in progress and send them a refresh in progress message rather than using the loading elapsed time.


WebFOCUS 8202M
Client: Windows Server 2012R2/Tomcat 8.0/IIS
Server: IBM i v7r2m0
MS-SQL
 
Posts: 28 | Location: Saskatchewan, Canada | Registered: March 03, 2011Report This Post
Master
posted Hide Post
sounds like a plan...but how do I programmatically check to see if a program is running and how do I measure (capture) the time?


WebFOCUS 8206.08
Windows, All Outputs
 
Posts: 603 | Registered: June 28, 2013Report This Post
Master
posted Hide Post
You will have to check the contents of the frame.

if it contains the text "please wait" ( or whatever you default wait html says ) then it isn't done.


_____________________
WF: 8.0.0.9 > going 8.2.0.5
 
Posts: 668 | Location: Veghel, The Netherlands | Registered: February 16, 2010Report This Post
Master
posted Hide Post
What would the code look like..I cannot seem to find a reference to that anywhere.

I do know we were taught to reference an HTML page (that says: 'Process Complete')...as the final statement of the fex...so the user sees: Loading...and when done (error or not) the html fills the box and says 'Process Complete...'

But I have know idea what /where to check for the process running...


WebFOCUS 8206.08
Windows, All Outputs
 
Posts: 603 | Registered: June 28, 2013Report This Post
Virtuoso
posted Hide Post
Robert

I have been waiting to see the answer to this as well because there are too many moving parts in this scenario...

You may need to open a case to see if this is really possible.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 2128 | Location: Customer Support | Registered: April 12, 2005Report This Post
Master
posted Hide Post
me too


Smiler


WebFOCUS 8206.08
Windows, All Outputs
 
Posts: 603 | Registered: June 28, 2013Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Messages on Dashboards

Copyright © 1996-2020 Information Builders