Focal Point
[CASE-OPENED] SQLBase Adapter Configuration

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/120101434

May 04, 2010, 04:06 AM
Clinton Side-Kick
[CASE-OPENED] SQLBase Adapter Configuration
Has anyone run into the following situation trying to configure the SQLBase adapter in WebFOCUS?

When connecting to SQLBase Datasource the following error returns:
(FOC1400) SQLCODE IS -1 (HEX: FFFFFFFF) XOPEN:
: (0) Ý ¨ 00296 DBO IVC Backend code page is not same, check SQL.INI
: file and country.sql
(FOC1405) SQL PREPARE ERROR.

It seems that the code page on the client side needs to be configured to be inline with the code page on the database server side.

This message has been edited. Last edited by: Kerry,


--------------------------------------------------------------------------------
prod: WF/AS 8.2.05; OmniGen;
In FOCUS since 1991
May 11, 2010, 04:45 PM
Kerry
Hi all,

FYI, it seems that Clinton or his collegue already has a case opened regarding this issue.

Clinton, if you have an update/solution later, can you please post it here? This way the info can be kept for future reference. Thank you in advance for sharing with all.

Cheers,

Kerry


Kerry Zhan
Focal Point Moderator
Information Builders, Inc.
September 30, 2010, 03:06 AM
peterbalmer
Hi all,

Clinton, were you ever able to solve this issue? I have the exact same problem. I am able to use country settings with the SQLTalk Gupta program but the WebFOCUS adapter does not pick it up.

I also have an open case with Techsupport.

Thanks,
Peter
October 08, 2010, 02:56 AM
peterbalmer
Hi All,

I have received message from techsupport that non-US Databasese are NOT supported by the JDBC Adpater.

Just for your info.

Sorry to hear it; I guess the only option would then be to use ODBC Adapter.

Peter