Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] .xls upload function

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] .xls upload function
 Login/Join
 
Silver Member
posted
Hello all,

I'm trying to use the DevStudio .xls upload function to dynamically create a file and associated master and I'm getting the following message after selecting the file and clicking "Next":

"An HTTP 500 error has been returned while processing the web components. The application server log contains information on why this error has occurred. Contact your application administrator or your software vendor support center for further assistance."

I tried this on two different machines. One localhost and the other zLinux.

Also, how do I get the server log files? Thanks

This message has been edited. Last edited by: Kerry,


Linux/zVM/WF7.6.11
 
Posts: 29 | Location: Washington DC | Registered: June 06, 2008Report This Post
Expert
posted Hide Post
Is it a large file? I have had trouble uploading a large file, so I create a copy with only 10 rows - upload that so that the Master gets generated, then copy the real file from the desktop to the server folder.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Silver Member
posted Hide Post
No, my test file has three columns and three rows.


Linux/zVM/WF7.6.11
 
Posts: 29 | Location: Washington DC | Registered: June 06, 2008Report This Post
Expert
posted Hide Post
From the documentation:

The Upload Data File option is available from the Master Files folder while developing in the Projects or Data Servers areas.

Upload Data Files


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Silver Member
posted Hide Post
Thanks, but it stops working at number 6:

"Click Next at the bottom of the Upload Data File dialog box."

.. and gives the error message after that. I made sure that there are no special characters, etc. Here is the data:

joefield1 joefield2 joefield3
aaa 1 1
bbb 2 2
ccc 3 3


Linux/zVM/WF7.6.11
 
Posts: 29 | Location: Washington DC | Registered: June 06, 2008Report This Post
Expert
posted Hide Post
Interestingly, I go through the motions of this function - I get a message that the file was successfully uploaded and Master created, but it does not show up in the app folder! I retry the upload and I get a message that the file already exists - I select replace, the file still does not show up in the app folder.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Expert
posted Hide Post
quote:
joefield1 joefield2 joefield3
aaa 1 1
bbb 2 2
ccc 3 3


I just created an EXCEL worksheet, 97-2003 .xls NOT EXCEL 2007 .xlsx, in 7.6.7, used your data and it worked fine...

I saved as BOOK1.xls, imported from Desktop, Selected Top Row contains Field Names, selected the Application folder, and was successful.

I am remote, working on a server at a NY University...

Tom


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Expert
posted Hide Post
I remember I had nothing but problems with this feature. I was told that the installed Java version must be what the Dev Studio requirements explicitly recommend - a newer version and nothing works.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Expert
posted Hide Post
Nope, just does not work, I must have a newer version of Java than what is required.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Expert
posted Hide Post
Hey Francis,

Don't have access to the JAVA version that's on the server. I'll find out...


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Silver Member
posted Hide Post
Possibly it is a Windows Vista, Windows 7, or Excel problem. I made sure to save the file in .xls (Excel 97-2003) format and it doesn't work, however, .csv DOES work under Windows Vista(64bit) on localhost. I'll keep playing with it.


Linux/zVM/WF7.6.11
 
Posts: 29 | Location: Washington DC | Registered: June 06, 2008Report This Post
Expert
posted Hide Post
It's the Java version of the PC where you're running Dev Studio.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Expert
posted Hide Post
H:\>java -version
java version "1.6.0_03"
Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
Java HotSpot(TM) Client VM (build 1.6.0_03-b05, mixed mode, sharing)


Probably not good for Dev Studio 7.6.8. The version of Dev Studio is also important.

I am not changing the Java version on my PC! I did what was recommended by I.B. Tech Support and downgraded Java and I ended up with a mess!


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Silver Member
posted Hide Post
That sounds like a probable cause. I'll leave this un-solved for now and use the .csv as a work-around. It would be nice to avoid that step, though. Thanks for the info!


Linux/zVM/WF7.6.11
 
Posts: 29 | Location: Washington DC | Registered: June 06, 2008Report This Post
Expert
posted Hide Post
 java version "1.6.0_03" 
Java(TM) SE Runtime Environment (build 1.6.0_03-b05) 
Java HotSpot(TM) 64-Bit Server VM (build 1.6.0_03-b05, mixed mode) 


7.6.7 Dev Studio, 7.6.10 Reporting Server, moving all to 7.6.11 at Fiscal Year close, end of June...

This is off the Reporting Server, that I remote in to...

FYI


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Expert
posted Hide Post
Behind the scenes with Upload File, IBI use apaches POI, a set of java classes that read Excel files. I think this is why the java version is important.



FYI

I should appologise, that an app I wrote years ago caused Upload File to be written. Big Grin


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] .xls upload function

Copyright © 1996-2020 Information Builders