Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Bottom of PDF Border gets eaten

Read-Only Read-Only Topic
Go
Search
Notify
Tools
Bottom of PDF Border gets eaten
 Login/Join
 
Silver Member
posted
I have several PDF reports that run across several pages and the bottom-line gets eaten on all the pages except the last page.

I have tried
ON TABLE SET PAGE NOLEAD

I have looked around other threads and tried the suggestion posted by some of the other members. None of them worked.

I am giving this in stylesheet
TYPE=REPORT,
BORDER-TOP=LIGHT,
BORDER-BOTTOM=LIGHT,
BORDER-LEFT=LIGHT,
BORDER-RIGHT=LIGHT,
FONT='ARIAL',
SIZE=10,
COLOR='BLACK',
STYLE=NORMAL,
RIGHTGAP=0.027778,
LEFTGAP=0.027778,
$

Can some one help please?

This message has been edited. Last edited by: dreddy_23,


Prod: WebFOCUS 8.1.05 on Win 10
Test: WebFOCUS 8.1.05 on Win 10
 
Posts: 43 | Registered: January 18, 2007Report This Post
Platinum Member
posted Hide Post
Hi,

Dont know if you already tried this, but try setting PRINTPLUS to on.

SET PRINTPLUS ON


WF 7.7.03/Windows/HTML,PDF,EXL
POC/local Dev Studio 7.7.03 & 7.6.11
 
Posts: 103 | Registered: June 12, 2009Report This Post
Virtuoso
posted Hide Post
Hi dreddy_23,

I don't think there is a solution to that. I have exactly the same behaviour in all of my reports and no matter what I tried in the past I never got the bottom border to show up in intermediate pages.

I think that we just need to learn how to live with this "feature Eeker At least I did! Frowner



Prod/Dev: WF Server 8008/Win 2008 - WF Client 8008/Win 2008 - Dev. Studio: 8008/Windows 7 - DBMS: Oracle 11g Rel 2
Test: Dev. Studio 8008 /Windows 7 (Local) Output:HTML, EXL2K.
 
Posts: 1533 | Registered: August 12, 2005Report This Post
Silver Member
posted Hide Post
Thanks Severus.snape!

I have tried both of this but no use.


Prod: WebFOCUS 8.1.05 on Win 10
Test: WebFOCUS 8.1.05 on Win 10
 
Posts: 43 | Registered: January 18, 2007Report This Post
Silver Member
posted Hide Post
Thanks for the reply njsden.


Prod: WebFOCUS 8.1.05 on Win 10
Test: WebFOCUS 8.1.05 on Win 10
 
Posts: 43 | Registered: January 18, 2007Report This Post
Expert
posted Hide Post
This can also happen with options like SUBHEAD, SUBFOOT, SKIP-LINE.

It is very difficult to fix, and I usually give up and leave it.

The only way I've been able to fix it is to work out when the botton line should appear, and force it to show, very complicated and convoluted.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Expert
posted Hide Post
I totally agree with Waz... WebFOCUS doesn't seem to keep track of the SUBHEAD, SUBFOOT, SKIP-LINE, etc very well, thus the body of the report spills over (is eaten). the complexity which Waz speaks of involves you (the developer) tracking the actual lines on each given page and doing your own page-break accordingly. It can be done. But, I think (imho) that IB should fix it...




   In FOCUS Since 1983 ~ from FOCUS to WebFOCUS.
   Current: WebFOCUS Administrator at FIS Worldpay | 8204, 8206
 
Posts: 3132 | Location: Tennessee, Nashville area | Registered: February 23, 2005Report This Post
Expert
posted Hide Post
I also agree that IBI should fix it.

Has anyone put a case in ?


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Expert
posted Hide Post
I think that we've all put up with it so long, that we've gotten immune to it...

I'll see what I can do about it IF someone comes up with a good example using a standard IBI file...

PM Me, along with your posted code, to ensure that I do not overlook it when it comes thru...
 
Posts: 3132 | Location: Tennessee, Nashville area | Registered: February 23, 2005Report This Post
Virtuoso
posted Hide Post
quote:
IF someone comes up with a good example using a standard IBI file...


I don't know how complete an example this might be but at least it illustrates the point:

SET PRINTPLUS = ON
TABLE FILE CAR
PRINT 
        CAR          AS 'Brand'
        MODEL        AS 'Model'
        BODYTYPE     AS 'Body Type'
        SEATS        AS 'No. of,Seats'
        DEALER_COST  AS 'Dealer,
        RETAIL_COST  AS 'Retail,Cost'
        SALES        AS 'Total,Sales'
BY COUNTRY NOPRINT
ON COUNTRY PAGE-BREAK AND SUBFOOT 
"TOTAL SALES IN <COUNTRY <ST.SALES"
HEADING
"Cars Inventory"
"Country:  <COUNTRY"
FOOTING BOTTOM
"Page No. <TABPAGENO  OF <TABLASTPAGE"
ON TABLE SET PAGE NOPAGE
ON TABLE PCHOLD FORMAT PDF
ON TABLE SET STYLE *
TYPE=REPORT, UNITS=PTS, SQUEEZE=ON, FONT='ARIAL', SIZE=9, BORDER=LIGHT, $
TYPE=TITLE, BACKCOLOR=SILVER, STYLE=NORMAL, JUSTIFY=CENTER, $
TYPE=SUBFOOT, BACKCOLOR=SILVER, BORDER=LIGHT, $ <-- BORDER keyword here is redundant!
TYPE=HEADING, LINE=1, SIZE=12, JUSTIFY=CENTER, STYLE=BOLD, $
TYPE=HEADING, LINE=2, OBJECT=TEXT, ITEM=1, STYLE=BOLD, $
TYPE=FOOTING, BORDER=OFF, BORDER-TOP=LIGHT, SIZE=8, JUSTIFY=RIGHT, $
END


This illustrates how both the LEFT and BOTTOM borders "disappear" from the SUBFOOT on each page except for the last one in which at least the BOTTOM border is present but the LEFT one is nowhere to be found. The situation is consistent throughout all of the reports we currently host.

Now, if you look closely at the heading's top border in pages 2 to 5, you will be able to spot a couple of mini-borders on both left and right sides ... it makes me think that this is actually the border chunk missing from the previous page and that somehow got pushed and collapsed onto the next heading. Well, that's just an assumption.

Caveat: This has consistently happened in my Production environment (WebFOCUS 5.3.4) although I am glad to report that, while creating this sample code I found out that it works as expected in my local Dev.Studio 7.6.10 (yay!) Well, bad news is there's no migration to WF 7.6 happening any time soon Frowner

Best,
- Neftali.



Prod/Dev: WF Server 8008/Win 2008 - WF Client 8008/Win 2008 - Dev. Studio: 8008/Windows 7 - DBMS: Oracle 11g Rel 2
Test: Dev. Studio 8008 /Windows 7 (Local) Output:HTML, EXL2K.
 
Posts: 1533 | Registered: August 12, 2005Report This Post
Virtuoso
posted Hide Post
quote:
it works as expected in my local Dev.Studio 7.6.10


Hey, wait a minute ... I can see that dreddy_23 actually has a 7.6.10 Production environment and he reported the issue as current. Sorry guys, I think my sample code is not that good an example after all Eeker

- Neftali.



Prod/Dev: WF Server 8008/Win 2008 - WF Client 8008/Win 2008 - Dev. Studio: 8008/Windows 7 - DBMS: Oracle 11g Rel 2
Test: Dev. Studio 8008 /Windows 7 (Local) Output:HTML, EXL2K.
 
Posts: 1533 | Registered: August 12, 2005Report This Post
Expert
posted Hide Post
There is a distinct difference in the way the borders are applied when individual items are used to TYPE=REPORT.

If TYPE=TITLE and TYPE=DATA, are used, then the bottom border is shown, but can be lines away from the data if PRINTPLUS is on.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Silver Member
posted Hide Post
Thank you all for the replies.

I have tried TYPE=DATA with PRINTPLUS=ON but that makes even worst with a line way to the bottom.

Dreddy.


Prod: WebFOCUS 8.1.05 on Win 10
Test: WebFOCUS 8.1.05 on Win 10
 
Posts: 43 | Registered: January 18, 2007Report This Post
Member
posted Hide Post
We have requested several "border" improvements / fixes with PDF output. This was one of the items that we discussed with IBI. Hopefully they will be able to include it in the 7.6.11 release.


WebFOCUS 7.7.02 Teradata, Oracle
Windows
Outputs: HTML / PDF / Excel
 
Posts: 13 | Location: Michigan | Registered: December 09, 2008Report This Post
Expert
posted Hide Post
Steve, did you put in a case with IBI ?


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Expert
posted Hide Post
I'm with Steve on this one... This should be fixed in 7.6.11 as per issues given to IB...

Good One Way To Go Steve...

We'll keep that sample (above) for a 7.6.11 test case...
 
Posts: 3132 | Location: Tennessee, Nashville area | Registered: February 23, 2005Report This Post
Master
posted Hide Post
Hi, all

I've got the same problem as dreddy_23.

Mine was fixed by just adding a dummy footer.

i.e.
TABLE
SUM A
BY B
ON B SUBFOOT
" "
.....

adding the green worked for me...

it's might help you aswell.

Greets,


_____________________
WF: 8.0.0.9 > going 8.2.0.5
 
Posts: 668 | Location: Veghel, The Netherlands | Registered: February 16, 2010Report This Post
Silver Member
posted Hide Post
quote:
Reply

Dave,

Thanks for your reply. i have tried your suggestion but It is still not working. I will keep trying with other options.

Thanks,
Dreddy


Prod: WebFOCUS 8.1.05 on Win 10
Test: WebFOCUS 8.1.05 on Win 10
 
Posts: 43 | Registered: January 18, 2007Report This Post
Member
posted Hide Post
This issue has not been resolved in 7.6.11.


WebFOCUS 7.7.02 Teradata, Oracle
Windows
Outputs: HTML / PDF / Excel
 
Posts: 13 | Location: Michigan | Registered: December 09, 2008Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Bottom of PDF Border gets eaten

Copyright © 1996-2020 Information Builders