Focal Point
[SOLVED by case] WF 7.6.9

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/129100413

December 10, 2009, 11:41 AM
om-cgi-bell
[SOLVED by case] WF 7.6.9
new Teradata 12 driver does not work with current "Teradata 300 ODBC" connections under Data Adapters:

FOC1261) PHYSICAL INTERFACE NOT FOUND FOR SUFFIX SQLDBC. MODULE NAME :
ODBPD300
(FOC1262) THE FOLLOWING NATIVE ERROR MESSAGE(S) CAPTURED :
(FOC1260) ld.so.1: tscom3.out: fatal: libodbc.so: open failed: No such file or
directory
(FOC1263) THE CURRENT ENVIRONMENT VARIABLES FOR SUFFIX SQLDBC ARE :
(FOC1260) ODBCINI : /bmppr/devl/Teradata/v12/Teradata/odbc/odbc.ini
(FOC1260) FASTLOAD_EXE : NOT SET
(FOC1260) MLOAD_EXE : NOT SET
(FOC1260) LD_LIBRARY_PATH : /ibi/common/oracle/lib32
(FOC1260) /bmppr/devl/jdk1.6.0_03/jre/lib/sparc/server
(FOC1260) /bmppr/devl/jdk1.6.0_03/jre/lib/sparc
(FOC1260) /bmppr/devl/wf/769/ibi/srv76/home/bin
(FOC1260) /bmppr/devl/Teradata/v12/Teradata/odbc/drivers
(FOC1260) /ibi/common/odbc/drivers
(FOC1260) /usr/ccs/lib
(FOC1260) /lib
(FOC1260) /usr/lib
(FOC1260) /usr/ucblib
(FOC1400) SQLCODE IS -1 (HEX: FFFFFFFF)
(FOC1400) SQLCODE IS -1 (HEX: FFFFFFFF)
(FOC1488) SQL INTERFACE HAS NOT BEEN INSTALLED OR COULD NOT BE INITIALIZED
(FOC1400) SQLCODE IS -1 (HEX: FFFFFFFF)
(FOC1488) SQL INTERFACE HAS NOT BEEN INSTALLED OR COULD NOT BE INITIALIZED
(FOC1479) ERROR CONNECTING TO SQL DATABASE

This message has been edited. Last edited by: Kerry,


WebFOCUS 52 and 53
Test: WebFOCUS 764
Unix
Output: Excel, HTML, Text, PDF
December 10, 2009, 11:56 AM
GinnyJakes
You might need to upgrade to 305 ODBC client. We are using Teradata 12 with that with no problem.

You should probably open a case as IBI can tell you exactly what you need.

Also, check out the release compatibility matrix on the Tech Support home page. That will tell you what you need for each server/adapter combo.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
December 16, 2009, 10:57 AM
Kerry
Hi all,

FYI, Omid opened a case regarding this issue and here is the solution from the case:

This issue was resolved, by including the path to required driver for ODBC "teragss" (/usr/teragss/solaris-sparc.32/12.00.00.00/lib) to the LD_LIBRARY_PATH variable in EDASTART (in "ibi/srv7x/wfs/bin"):

export LD_LIBRARY_PATH=/ibi/common/teradata/lib:/opt/tdicu/lib:/ibi/common/cliv2:/ibi/common/cliv2/lib:/usr/teragss/solaris-sparc.32/12.00.00.00/lib:/ibi/common/odbc/drivers:/ibi/common/odbc/lib:$LD_LIBRARY_PATH

Thank you Omid for sharing with all.

Cheers,

Kerry


Kerry Zhan
Focal Point Moderator
Information Builders, Inc.