Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Obtaining user email

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] Obtaining user email
 Login/Join
 
Master
posted
Hi all,

I'm trying to make an 'email-me' button. ( Managed Reporting )

But I'm unable to retrieve the user's emailaddress. ( yes, we do supply it when adding users )

It's not in the &IBIMR_ parameters I have.
Perhaps I can add it ( pass etc.. )
But I'm unable to find a complete list of all parameters that are passable?
only : "Useful variables include".


I'm able to get it using this:
http:///ibi_apps/WFServlet?IBFS1_action=getUser&IBFS_name=dave


But I need it in FEX, not script.
Although I know a workaround to get it, I find it very odd that I can not query the repository nor find it in the internal parameters?


greets,Dave

This message has been edited. Last edited by: Dave,


_____________________
WF: 8.0.0.9 > going 8.2.0.5
 
Posts: 668 | Location: Veghel, The Netherlands | Registered: February 16, 2010Report This Post
Expert
posted Hide Post
If you add it to the user via the security centre, then you'll locate it in UOA_USERS.

However, if you are using external authentication then I am not sure if this is brought in to the repository or not.

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
Expert
posted Hide Post
The email does get populated with external security, at least with our external security set up.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Master
posted Hide Post
Thanks so far...

We use single-signon with WIA ( AD ), whatever you call it.

Windows-account.

But we do explicitly add users to Webfocus.
We, manually, provide email-address there.

only thing to do is find out how to access UOA_USERS.
[ have to talk to the admin's ]

Greets,dave

This message has been edited. Last edited by: Dave,


_____________________
WF: 8.0.0.9 > going 8.2.0.5
 
Posts: 668 | Location: Veghel, The Netherlands | Registered: February 16, 2010Report This Post
Expert
posted Hide Post
Hi Dave,

UOA_USERS is a table withn the WF Repository, so it depends on what RDBMS you use - If you use the standard Derby then you would need a JDBC adapter licence otherwise the adapter licence for the RDBMS that you use.

Also see if "Synchrobise User Information" is available on the release that you are using.

Is there any prospect of you upgrading? Or are you planning on sticking on 8.0.09?

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
Master
posted Hide Post
Hi, Tony,

thanks for the swift reply.

I think the repository is in SQL-server somewhere. ( or even Teradata ).
I'll have to talk to the admins.



We're right in the middle of upgrading to 8203
Client and Servers installed, but some trouble getting it up and running. ( authorisation, dmz, ports, ip's etc. )

Then we're going to 'sandbox' it for a while, see what we can do.
After that's we'll move to 8203.

I use the word 'move' because we will not migrate 'as is'.
New autorisations, new portals, etc.etc.

We did a migration from 7 to 8, and now we're stuck with a lot of legacy WF7 stuff. E.g. autorisation based on Domains etc.

Great oppurtunity to get rid of that...


_____________________
WF: 8.0.0.9 > going 8.2.0.5
 
Posts: 668 | Location: Veghel, The Netherlands | Registered: February 16, 2010Report This Post
Expert
posted Hide Post
Good luck Smiler You'll appreciate the improvements from 8.0.09

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
Master
posted Hide Post
Got it!
it works..


_____________________
WF: 8.0.0.9 > going 8.2.0.5
 
Posts: 668 | Location: Veghel, The Netherlands | Registered: February 16, 2010Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Obtaining user email

Copyright © 1996-2020 Information Builders