Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Developer Studio - Failed to Load Master List

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] Developer Studio - Failed to Load Master List
 Login/Join
 
Member
posted
I've upgrading from WF8.0.0.4. to WF 8.0.0.7

I have a strange behavior. From the developer studio if I want to create a chart I choose Master data, for example in CAR ibisamp folder, appear to open but return the following error: An unrecoverable error has occurred. We are sorry for the inconvenience. If I click the exit button on this error message the tool closes. If I click In more information button i've this information:


Code: 1021 Type: xFDMinit
Failed to Load Master List

Code: 1021 Type: xFDMinit
An invalid XML character (Unicode: 0x1a) was found in the element content of the document.

Code: -1 Type: xFDMinit
An invalid XML character (Unicode: 0x1a) was found in the element content of the document.

If I create the chart from the BIP in content folder, I get no error. Access the report right click, choose open with Info Assist and the report opens without error. Even if the developer choose to open the same, I get no error.

If I copy the same .Fex into ibisamp folder and try to open it with the developer studio, info assists while trying to open I get the same error.

What could have happened?
Thanks

This message has been edited. Last edited by: dr.herojos,


WebFOCUS 8.2 Relase 8203 Build Gen 43
DataMigrator 8203M Gen Number 1337
Windows, All Outputs
 
Posts: 23 | Location: Bari - Italy | Registered: October 20, 2013Report This Post
<Kathryn Henning>
posted
Hi dr.herojos,

This error message can be caused by a number of things. I'll mention the two most common here.

First (this assumes that you're using Tomcat with Windows which may not be the case):
1. Stop Apache Tomcat
2. Navigate to your Tomcat folder in Windows Explorer (For a default install - C:\ibi\tomcat\)
3. Delete the entire folder with the name 'work'
4. Restart Apache Tomcat from your services menu

If this doesn't apply in your environment or doesn't resolve the issue, then there’s probably a single offending Master file. Make a copy of your edasprof.prf file, and then totally clear the app path except for ibisamp and baseapp.

If this fixes the problem, you will need to re-add the app folders to the path 1 by 1 and re-test until you find which app folder causes the problem.

Then, once you know which app folder is creating the issue, you can inspect the individual Master files in that folder and figure out which ones needs fixing.

If neither of the above resolve the issue, please open a case on InfoResponse Online so that we can work with you on this issue.

Thanks and regards,

Kathryn
 
Report This Post
Gold member
posted Hide Post
Hi dr.herojos,
Try to shorten the name of the master file.
Also check if there is any master file that exceeds the character limitation for the name.
Is it the specific master file or does this error occur for any master file?


7.7.01,windows2008 R2
 
Posts: 65 | Registered: July 28, 2011Report This Post
Member
posted Hide Post
Thanks to all, the problem was a corrupt MFD. I deleted the MAS wrong and everything works fine again.


WebFOCUS 8.2 Relase 8203 Build Gen 43
DataMigrator 8203M Gen Number 1337
Windows, All Outputs
 
Posts: 23 | Location: Bari - Italy | Registered: October 20, 2013Report This Post
Silver Member
posted Hide Post
Hi dr.herojos,

What is the meaning of MFD?. I am also facing the same issue and not able to rectify it.

I am getting the error code as "Code: 1017 Type: xFDMinit"Parent not found for cube Metadata fieldname = '[FielName/TableName].

can you please help me on this.

Regards,
Suresh


WebFOCUS 8.0.05 - BI Portal, Developer Studio, Dev/App Studio, Excel, PDF, Active Formats and HTML5, Adobe Flex Builder, VBA
 
Posts: 47 | Location: Bengaluru, India | Registered: December 04, 2014Report This Post
Virtuoso
posted Hide Post
MFD = Master File Definition

Try dr.h solution by deleting your MAS file and create it back again.


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2410 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Developer Studio - Failed to Load Master List

Copyright © 1996-2020 Information Builders