Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Problems displaying Image in PDF report
Go
New
Search
Notify
Tools
Reply
  
Problems displaying Image in PDF report
 Login/Join
 
Member
posted
Hi,

I've reviewed previous posts regarding images in PDF reports. I've followed examples but I'm still having problems.

This is my code:

-*SET BASEURL=http://rrbwebprod22/ibi_html/

-*TABLE FILE CAR
-*PRINT CAR MODEL SEATS
-*BY COUNTRY
-*ON TABLE SET ONLINE-FMT PDF
-*ON TABLE SET STYLE *
-*TYPE=REPORT, IMAGE=IB_LOGO.gif, $
-*ENDSTYLE
-*END

If I remove 'PDF' format, the image is displyed, otherwise I get an error:

(FOC3202) BAD VALUE IN STYLESHEET FILE AT LINE: 1 IMAGE=IB_LOGO.gif

Can anyone help me? Thank you.

Margaret
We have WebFOCUS 5.3.
 
Posts: 12 | Registered: March 30, 2006Reply With QuoteReport This Post
Virtuoso
posted Hide Post
I have an image in a PDF and had to add this at the beginning for it to be located.
IMAGE=http:\\server\approot\chddb_magic\ logo.gif,


In Focus since 1993. WebFOCUS 7.7.03 Win 2003
 
Posts: 1903 | Location: San Antonio | Registered: February 28, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
For PDF, the image has to be in an App folder that is defined in the App Path.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
Hi Margaret,

Has this issue been resolved? Did Prarie and Francis' suggestions help you? Many thanks to both Prarie and Francis. Wink

I am wondering, if you add the full address/URL of the image to IMAGE = (here is the full address/URL), will that work fine?

I also ran some search on Information Builders' online document and came across the following topics which may be of interest:

Summary: not able to display graph image in compound pdf report

How to apply conditional styling with multiple (AND/OR) conditional values

Hope this helps. Big Grin

Cheers,

Kerry


Kerry Zhan
Focal Point Moderator
Information Builders, Inc.
 
Posts: 1950 | Location: New York | Registered: November 16, 2004Reply With QuoteReport This Post
Member
posted Hide Post
Hi Kerry,

I've specified full url, baseurl, it didn't help. edasprof contains mapping to the image library, but I'm still having problems.

Margaret
 
Posts: 12 | Registered: March 30, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
Margaret, is the image in an APP folder? Is your report in MRE?


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
Margaret,

Almost everyone gets hung up on this problem at some stage and the main reason (that I can see) is the understanding of where an image file needs to reside to be picked up by a particular format.

HTML output is built in the browser and therefore the image file HAS to be available via a URL. So the image file must exist on a server that is available to the web.

However, PDF output is built on the Reporting Server BEFORE being sent to the browser and therefore the image file HAS to be available to the Reporting Server and therefore (as Francis states) in a folder available in the APP PATH (or EDAPATH). A URL is no use in this instance.

If you are adding a Logo image to a heading on your report, then I would suggest you copy it using the op system (WebFOCUS will not copy JPEGs successfully - gifs are OK though) to the BASEAPP folder on your Reporting Server. Because the BASEAPP folder is normally included within the APP PATH (Use APP SHOWPATH to check) the image file should always be available to PDF format reports.

There are occasions when the image file seems to work when contained on the Client Server and this is (usually) when both the Client and Reporting Servers are installed on the same physical machine and have the same root directory.

Hope this helps.

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5693 | Location: United Kingdom | Registered: April 08, 2004Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Problems displaying Image in PDF report

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.