Focal Point
[SOLVED] Eliminating Description on MFDs

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/1587062495

November 24, 2010, 03:15 PM
Stan
[SOLVED] Eliminating Description on MFDs
Okay, so I'm sure I've done this once before on a different version, but where can I set my system to not place the Description line in the Master File 'Synonyms' when using the WebFOCUS console. I know there was a place I could do something like 'SET DESCRIPTION OFF' but I can't recall where to put that.

This message has been edited. Last edited by: Kerry,
November 24, 2010, 03:44 PM
Stan
Found my own answer - I needed to put SET SYNONYM=BASIC into the edasprof.prf file.

We have a WebFOCUS program that 'reads' the MFDs out of their library and it does not expect those description or remark lines to be there or it ends up garbling them on the display. The setting above resolved my issue.
November 25, 2010, 07:19 AM
Håkan
There is another way of doing it. Include this line on the top of .mas.

/*NOCOLS*/
FILENAME=tablename, SUFFIX=SQLMSS , $
SEGMENT=segname, SEGTYPE=S0, $

Then WF will dynamically retrieve the column names and formats.

If you use the Data Management Console there is an option in for Dynamic columns when you create a synonym.

/Håkan


WebFOCUS DS 8.0.06/08 DS/AS
WebFOCUS RS 8.0.08 (Linux/IBM i)
WebFOCUS Client 8.0.06 (Linux)