Focal Point
[SOLVED]Why WebFOCUS Forum Discussions on Focal Point have (always?) report code?

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/1787050396

April 07, 2020, 05:09 PM
Manoj
[SOLVED]Why WebFOCUS Forum Discussions on Focal Point have (always?) report code?
Hi,

Apologies this is not a question related to InfoAssist or BI Portal.

Why (all) discussions (that is questions and answers) have code like 'TABLE FILE car ...'?

Why do they not include InfoAssist / BI Portal screenshots?

I am new to WebFOCUS product suite (InfoAssist and BI Portal only) and when I am looking for some answer I am finding it bit difficult to understand the explanation. Sometimes I feel there is answer (which uses TABLE FILE car code) to my question but I am not able to know how it's done in InfoAssist.

Please can someone help me know the reason?

Many thanks.

Kind regards,

Manoj.

This message has been edited. Last edited by: Manoj,


Newbie.
WebFOCUS 8.2.0.3.
Client 8.2.0.4.
April 07, 2020, 05:41 PM
Waz
Funny, I thought that there was an InfoAssist forum.

My opinion is that there are a lot of "old timers" (coders) in the forum, and that is out go to for replication of the issues.

With InfoAssist, you can still build a repro in it, and view the source (if you are allowed) and post the underlying code.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

April 08, 2020, 04:23 AM
Tony A
Add to that the difficulty for many of hosting an image somewhere that they can reference on FP.

I'm sure if you ask a question and mention that you need to achieve this in Designer or InfoAssist, then responders would do their best to respond accordingly.

Many posters already include their code from InfoAssist so it should be fairly obvious where they need a solution. But as Waz mentions, there are probably a large number of members who prefer coding to using a GUI!

As for the InfoAssist forum, I think that was not well visited and fell by the wayside.

To reiterate, if you need an InfoAssist method, say so!

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
April 08, 2020, 10:57 AM
FP Mod Chuck
Manoj

Tony is right on. Images have been an issue on this forum because you can't post them directly you have to go through a outside site that a lot of companies block due to security issues. I know IBI is currently looking for other community options to help resolve this. The infoassist forum was not used so all WebFOCUS questions are posted on this forum.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
April 08, 2020, 11:15 AM
dbeagan
I think your question touches on a larger issue and there was a good discussion on it five years ago:

Code or GUI


WF 8.2.06
Win10 / IE11
AHTML EXL2K PDF
April 08, 2020, 02:27 PM
David Briars
Thanks for sharing the link to that earlier thread, dbeagan.
April 08, 2020, 03:30 PM
Doug
Excellent points. I like pictures
Pictures are worth a thousand words

... When that are visible.

InfoAssist: I think 'WE' decided to include "InfoAssist" as a required prefix to the subject like when appropriate.

Images: Perhaps IBI can act like a '3rd Party" app service to accommodate images. Although, as Chuck stated "...a lot of companies block due to security issues..."




   In FOCUS Since 1983 ~ from FOCUS to WebFOCUS.
   Current: WebFOCUS Administrator at FIS Worldpay | 8204, 8206
April 08, 2020, 04:09 PM
Manoj
Thank you all for your time and answering the question. I wanted to know as I wanted to avoid situation where my question would have already been answered. I am confident I shall be in a situation where I can read the code and use a solution/workaround, if applicable.

If not or I am not able to figure out, I shall ask with "InfoAssist" included in the discussion.

Thank you. _/\_
Kind regards,
Manoj.


Newbie.
WebFOCUS 8.2.0.3.
Client 8.2.0.4.
April 09, 2020, 08:01 PM
Hallway

I found a cool way to post pictures without having to host them, and that is to convert them into a base64-encoded string.

However, that only works if the base64 encoding does NOT contain three of the letter 'K' in a row. Apparently Eve forums thinks that it's posting something racial.

🤦‍♂️



Hallway

 
Prod: 8202M1
Test: 8202M4
Repository:
 
OS:
 
Outputs:
 
 
 
 
April 09, 2020, 08:34 PM
FP Mod Chuck
Hallway

What do you use to convert them to the base64-encoded string?


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
April 13, 2020, 04:24 PM
Hallway
quote:
Originally posted by FP Mod Chuck:
Hallway

What do you use to convert them to the base64-encoded string?


I built an encoder using JavaScript. You can see it on my CodePen page: https://codepen.io/steebn/full/JjYdVxr


Hallway

 
Prod: 8202M1
Test: 8202M4
Repository:
 
OS:
 
Outputs:
 
 
 
 
April 13, 2020, 05:59 PM
FP Mod Chuck
Hallway

Very cool I have put this link in my bookmarks!


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
April 14, 2020, 07:32 AM
dbeagan
Looks like the base64 image works.

.
.
.
.

This message has been edited. Last edited by: dbeagan,


WF 8.2.06
Win10 / IE11
AHTML EXL2K PDF