Focal Point
[CLOSED] App Studio 8009 very slow to save a file

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/1927040476

December 24, 2014, 10:37 AM
tnicholas
[CLOSED] App Studio 8009 very slow to save a file
We just reciently installed App Studio 8009 and it is very slow like 2-3 minutes to save a file. Does any one know why this is happening and is there a eway to fix it?

Thanks, Todd

This message has been edited. Last edited by: <Kathryn Henning>,
December 29, 2014, 10:06 AM
Kevin W
We are on Windows and installed a Microsoft patch file named Windows6.1-KB2675785-x64.msu that fixed the problem. I'm not sure where our admins found it.


WebFOCUS 7.7.05 (Someday 8)
Windows 7, All Outputs
In Focus since 1983.
January 22, 2015, 02:23 PM
tnicholas
Yes, we added the patch today and we still have the same problem.

Thank you for your help.
January 23, 2015, 10:57 AM
Kevin W
Open a ticket with IBI. As we upgrade to WF 8.0.0.9 we are finding some interesting things. Although this save is no longer one of them. Wink


WebFOCUS 7.7.05 (Someday 8)
Windows 7, All Outputs
In Focus since 1983.
January 23, 2015, 11:16 AM
Jay Potter
Could you give us some hints to the interesting things? I have also upgraded to 8.0.9 and one of the things I found is that images with in the header are not displaying when using IE11. I have just been told yesterday that there has been a refresh to the client server 8.0.9 that takes care of that. I have not pulled it down yet.

I also have slowness when using AppStudio. Right now I am using both DevStudio and AppStudio. DevStudio for my old HTML files and I build new ones with AppStudio.


WebFocus 8.1.5
iSeries/Windows
DB2/SQL/Access
Dev Studio
App Studio
Maintain
ReportCaster
January 26, 2015, 07:50 AM
mrguru
I have the same issue and have a case opened with IBI. I have noticed that the slowness in the save is for any application that is in the 'app path'. Check and see if that is the case with you. If so, it could help in getting this issue resolved.


WF 8.2.01M
8.2.01M Reporting Server
Windows 2012 Srvr R2
PDF,Excel, HTML
Graphs - a lot of graphs
January 26, 2015, 08:09 AM
Jay Potter
I am having the problem when saving within the content. In my case it doesn't make a difference whether it is within the 'app path' (reporting server) or within the content. They are now both on my iSeries. They are both data files and I believe they are accessed more or less the same way. I believe part of my problem may be the priority that any IB job has on my iSeries.


WebFocus 8.1.5
iSeries/Windows
DB2/SQL/Access
Dev Studio
App Studio
Maintain
ReportCaster
January 26, 2015, 10:54 AM
Kevin W
There was (is?) a discussion devoted to the things people have found during upgrade. I have nothing to add. As I said earlier, our slow saves went away with the MicroSoft patch. It has helped us to work directly with IBI via tickets.


WebFOCUS 7.7.05 (Someday 8)
Windows 7, All Outputs
In Focus since 1983.
April 08, 2015, 04:52 PM
AK_Guy
We are on WF 8.0.09 and have found AppStudio to slow over all. We have not moved to AppStudio from DevStudio because of this issue. Actually… the only decent piece of WF 8 that I’ve found is ReportCaster. Having said that, we don’t use maintain or the ETL tool set. But nothing else seems ready for prime time.


WebFOCUS 8.0.09
Windows 7
Output: Excel, PDF, HTML
April 09, 2015, 04:04 AM
Wep5622
We saw this too when we had a couple of IBI consultants over who were using app studio. We found that saving files from app studio used a full CPU core on the reporting server (load 25% on a quad-core CPU), which would probably explain the slowness witnessed on the client-side.

We did not find out why that was happening though.

Another user here who started using app studio recently doesn't have the problem (and isn't causing a core to be loaded 100%).


WebFOCUS 8.1.03, Windows 7-64/2008-64, IBM DB2/400, Oracle 11g & RDB, MS SQL-Server 2005, SAP, PostgreSQL 11, Output: HTML, PDF, Excel 2010
: Member of User Group Benelux :
April 09, 2015, 09:04 AM
Carl Wangberg
We've notice that App Studio is also very slow. The interface itself is very slow to respond, opening the tools takes quite a while, and navigating around is just sluggish. We happen to install with a remote server, no local server, and I believe that is compounding the issue and making it much more apparent. We do have a case opened on this but not sure where it's headed.

Not sure how many other people install with a remote server, but there were a number of issues with that as well. We did get it working, but had to do some cleanup after the install.


WebFOCUS and Data Migrator
April 09, 2015, 09:16 AM
Francis Mariani
I plan on not using App Studio until we install WF 8.1.03 or newer.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
April 09, 2015, 10:47 AM
Kevin W
Still slow in 8.1.03. We are continuing to use Dev Studio most of the time.


WebFOCUS 7.7.05 (Someday 8)
Windows 7, All Outputs
In Focus since 1983.
April 09, 2015, 10:57 AM
John_Edwards
I have Dev Studio 7.7 on a laptop that I run at two different clients. On one network the save time is too short to measure, on the other it's about 20 seconds. No clue what the difference is, but it's clearly beyond the borders of my laptop.

J.



June 23, 2015, 11:27 AM
KenFR
quote:
Is DevStudio still running faster than AppStudio? I'm converting the masses to 8009 from 7703 now and response is horrible. I opened a ticket last week, but don't have a fix yet.
Any good tuning tricks found yet?



8105 Tomcat and AIX reporting server
input: Teradata, SQL, DB2, Essbase, Oracle, text
output:html, excel, PDF,
June 24, 2015, 10:23 AM
Kevin W
We found a work around of sorts. It depends on the amount of content in the destination folder. So we create a working folder with just our current item in it. We save here as we are working on code. We only take the slowness hit when we make the "final" save to the folder where the report ultimately resides. I think I heard something about the IBI code walking the entire directory before saving. I believe they are implementing a solution. I don't know how far back they will port it into the release 8 series. It is not in 8.1.03 with us.


WebFOCUS 7.7.05 (Someday 8)
Windows 7, All Outputs
In Focus since 1983.
July 09, 2015, 02:41 PM
RRKen
8007, 8009, 8009 w/hotfix, and 8009 with windows patch have been absolute flops because of very slow read/write times on our low latency network. IBI is suggesting 8104 now, but I've never had good luck with newer releases and just don't trust going through yet another install in hopes of getting usable software. I guess we are stuck with 77x for another year.


8.2.03 AIX Client Windows Tomcat
DB2, Terradata, SQL, Oracle
July 10, 2015, 09:08 AM
BarryS
Hi

App Studio 8105 has been rewritten to enhance performance. I have not tested but lets hope that the slowness has been addressed.

Thanks Barry


WebFOCUS 8103, Windows, App Studio
July 10, 2015, 09:18 AM
Jay Potter
The sad thing about this is that you can't learn AppStudio if it is slow. If you try to go from 8.0.9 to 8.2.XXX, you loose the grace period of learning AppStudio and still having DevStudio has a backup. I believe DevStudio will not work in 8.2.XX and there is a learning curve for AppStudio.


WebFocus 8.1.5
iSeries/Windows
DB2/SQL/Access
Dev Studio
App Studio
Maintain
ReportCaster
April 19, 2016, 04:49 PM
RRKen
Fixed by changing the SQL connection strings in the edasprof.prf. There were 30 or so that were all in a format for an older version of java than the new install. I was not using SQL so did not think anything of it (db2 repository); but each time I saved a fex it was running through edasprof and lagging. Comment them out and lag goes away; fix the format and no more lag. No error on startup btw


8.2.03 AIX Client Windows Tomcat
DB2, Terradata, SQL, Oracle