Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     dashboard:what is the exact form of a url to a .htm
Page 1 2 

Read-Only Read-Only Topic
Go
Search
Notify
Tools
dashboard:what is the exact form of a url to a .htm
 Login/Join
 
Expert
posted
i have a links block
a link can call an html launch page in the domain
ok..
but what i want to do
is have that link call an html [b]frameset[b]
and have that frameset call the launch page.
What's the url s'posed to look like
that i write in the frameset to call the launchpage in the mre domain?
If i could VIEWSOURCE on a links block entry, i could see...but that's locked out.
Piece o' cake from iis, but from w/in mre, i'm lost.
What i don't want to do is replace launch pages with fexes...just because they're addressable.

any ideas?




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Expert
posted Hide Post
Hi Susannah,

Sorry I missed YOU at Summit, I was looking for you at the Tips and Techniques; NO SHOW!!! Oh Well, another time maybe. Are you going to FUN in August????

Anyway, IF you'd like to PM me and put what you want in a WORD doc, pictures, please, I'd be glad to help. I "think" I have an idea, but, a picture is worth a 1000 words...


FYI: I cheat; I call a FEX from MRE which has


  
-HTMLFORM program.htm 


Tom

This message has been edited. Last edited by: Tom Flynn,


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Expert
posted Hide Post
tom, ala! how did i miss you! during T&T i was in a lab...i'm so sorry i missed the party!
thanks for your suggestion...it was my only workaround...but i really didn't want to have to do it. i want to try to figure out how to call the .htm page...

One reason is that the iframe thing is horrid.
you can't print directly from an iframe. it only prints the wee bit that actually shows. iframes are for demos...
Another reason is that i want to create a 2nd row of tabs..and i gotta have a frameset to do it.

FUN in August i won't make this year, i'm on a september deadline, so i'll be working more hours then ever. sorry to say, i love FUN. and its at a different hotel this year...

This message has been edited. Last edited by: susannah,




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Expert
posted Hide Post
Susannah,

Check out this thread


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Expert
posted Hide Post
Hey Susannah,

This year it's at Foxwoods Resort & Casino outside of Concord, MA.

Perfect time of year in MA...

I guess there's always next year's Summit...

Tom


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Expert
posted Hide Post
ohhhh
very valuable
thanks tom.
i was told that Stu was the go-to guy for this stuff. I'll ask him visit this thread.




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Expert
posted Hide Post
Susannah,

Actually, we print from iframe's all the time; we have a PDF, EXCEL and AHTML icon above and on the right side of the frame....

Tom


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Guru
posted Hide Post
Susannah,

Based on your initial post, I believe that your main problem is the URL to call the launch page from within the frameset, if that is incorrect please let me know and I'll try again.

Here is a basic frameset page that calls 3 html pages (header.htm, left.htm and launch.htm) from within the Default MRE domain (untitled/untitled.htm).

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
   "http://www.w3.org/TR/html4/frameset.dtd">
<HTML>
<HEAD>
<TITLE>A simple frameset document</TITLE>
</HEAD>
<FRAMESET rows="125, 1*">
  <FRAME name="header" src="WFServlet?IBIMR_action=MR_RUN_FEX&IBIMR_sub_action=MR_STD_REPORT&IBIMR_fex=app/header.htm&IBIMR_domain=untitled/untitled.htm&IBIMR_folder=#testysyr82m2&">
  <FRAMESET cols="20%, 80%">
      <FRAME name="menu" src="WFServlet?IBIMR_action=MR_RUN_FEX&IBIMR_sub_action=MR_STD_REPORT&IBIMR_fex=app/left.htm&IBIMR_folder=#testysyr82m2&IBIMR_domain=untitled/untitled.htm&">
      <FRAME name="content" src="WFServlet?IBIMR_action=MR_RUN_FEX&IBIMR_sub_action=MR_STD_REPORT&IBIMR_fex=app/launch.htm&IBIMR_folder=#testysyr82m2&IBIMR_domain=untitled/untitled.htm&">
  </FRAMESET>
  <NOFRAMES>
      <P>This frameset document contains:
      <UL>
         <LI>A header section at the top
         <LI>A menu on the left
         <LI>The main content of the page
      </UL>
  </NOFRAMES>
</FRAMESET>
</HTML>


You may also want to add a [b]&IBIMR_Random=[b] to the end of the URL line and some of the URL may need to be "escaped" to make it HTML safe (ie # -> %23, . -> %2e, / -> %2f).

The easiest way to grab the URL is to run the HTML page from within the MR applet and grab the URL from the browser address bar, but tools like fiddler (www.fiddler2.com) will also show you what is being called.

Unfortunatly, dev Studio doesn't like framesets, so I strongly suggest you don't try edit the frameste page using HTML layout painter without making a back up first.

I haven't tested this against 7.1.6, but it does work for 762, 764 and 765.

Cheers

Stu


WebFOCUS 8.2.03 (8.2.06 in testing)
 
Posts: 253 | Location: Melbourne, Australia | Registered: February 07, 2007Report This Post
Expert
posted Hide Post
ooooohhhhh
so you call the .htm the very same way you would call a .fex?
i never thought of that.(i'm a billgates brain)
sounds so clear.
good point about the escape characters.
I had gotten this to semi-work by calling fexes that -htmlform'd a .htm
but its messy.
boy, thank you so much Stu.

aha. tested and works like a charm.

This message has been edited. Last edited by: susannah,




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Expert
posted Hide Post
quote:
&IBIMR_fex=app/header.htm


That is new to me too! I hadn't realized you call an HTML file like a fex in MRE.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Expert
posted Hide Post
but it makes such perfect sense, doesn't it.
since you can right click run a .htm from devstu the very same way you right click run a .fex, why not?
but my billgates brain would have blocked that out...
Stu rocks!




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Expert
posted Hide Post
i'm finding that Tom's way of calling a .htm from within its own .fex has the advantage of letting you seed a STARTDATE (for your calendar), so very easily.
no javascript and no ageda.
FEX:-----------------------------
-DEFAULT &STARTDATE=&YYMD.EVAL ;
(or whatever you want to do in regular dialogue manager to your dates)
-HTMLFORM mylaunchpage.htm
---------------------------------
and in mylaunchpage.htm
first, escape all the & with &|
and second
replace value="" with value=!IBI.AMP.STARTDATE;
in your startdate variable in your form.
and you're good to go.
so simple ...if you're in MRE
if you're in iis self serv, javascript is still the way to go, because your launch pages are/should be soooo much purer.




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Gold member
posted Hide Post
I'm trying to link to a MRE html page from outside of mre. I tried using your URL from above but it is giving an error. Cannot execute the request. Please log into MRE. Can you please tell what I am doing wrong. Or is this not possible.

http://dotscomrep1/ibi_apps/WF...&IBIMR_pass=password
 
Posts: 84 | Location: Tallahassee, Fl. | Registered: December 02, 2005Report This Post
Expert
posted Hide Post
Mike,

There are three additional MRE parameters to look into:

&MR_AUTOSIGNON=YES|NO
&MR_ANONYMOUS_RUN_ACCESS=YES|NO
&IBIMR_drill=RUNNID

Search for these parameters in this forum or on the Tech Support site.

I have to say it's quite confusing. It appears adding only &IBIMR_drill=RUNNID to a URL like yours works, but the login is done using the cookie that may have previously been created by a normal MRE Login.

The other two parameters are new to me.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Expert
posted Hide Post
Mike
i can get you to an entire dashboard view
<A target='_top' HREF="/ibi_apps/Controller?WORP_REQUEST_TYPE=WORP_GBV_VERIFY&|WORP_USER=&USER_ID&|WORP_MPV=al_gbv">




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Report This Post
Gold member
posted Hide Post
I added the parameter &IBIMR_drill=RUNNID this gets me to the HTML page but does not function. Prompts me to log into MRE when I click on Submit. I also added the other two parameters &MR_AUTOSIGNON=YES and &MR_ANONYMOUS_RUN_ACCESS=YES along with a user id and password with the same results. I will search for more help on these paramters.
 
Posts: 84 | Location: Tallahassee, Fl. | Registered: December 02, 2005Report This Post
Gold member
posted Hide Post
Well, I searched for the patameters. I did not find anything on IBI site. I found two other post on the forum. Look like the parameters &MR_AUTOSIGNON=YES|NO
&MR_ANONYMOUS_RUN_ACCESS=YES|NO
only work for verson 7.6.4 and higher. which we are currently on version 716. I will keep looking.
 
Posts: 84 | Location: Tallahassee, Fl. | Registered: December 02, 2005Report This Post
Silver Member
posted Hide Post
You might need to make a signon-Request before calling the report.

https://server.domain/ibi_apps...MR_action=MR_SIGNON&
IBIWF_language=de&
SIGNON_CORRECT=%2Fibi_apps%2FWFServlet%3FIBIF_ex%3Dreport1%26IBIMR_proxy_id%3D&
SIGNON_CORRECT_ADMIN=%2Fibi_apps%2FWFServlet%3FIBIF_ex%3Dreport1%26IBIMR_proxy_id%3D&
SIGNON_CRT_DOM_ADMIN=%2Fibi_apps%2FWFServlet%3FIBIF_ex%3Dreport1%26IBIMR_proxy_id%3D

Maybe you need the IBIMR_user and IBIMR_pass as well in order to do that.

This signon-Request creates the MR-Cookie needed in order to execute requests.


WF 7.6.6 (MRE,BID, DevStudio, partly RC) on Windows 2003 /Apache/Tomcat
Output: HTML,Excel,PDF,PPT
Adapters: SQL Server, DB2, Oracle
 
Posts: 38 | Location: Austria, Linz | Registered: June 19, 2009Report This Post
Gold member
posted Hide Post
Your URL seems to work upto a point. It's logging into MRE but it can't find the report. I have tried including the folder location perhaps I'm using the wrong parameter name. I will do some more research on the parameters you shown in this url. Thanks for the help.

Here is the url I'm trying.

 http://dotscomrep1.dot.state.f...&IBIC_server=WFWINP1 
 
Posts: 84 | Location: Tallahassee, Fl. | Registered: December 02, 2005Report This Post
Expert
posted Hide Post
&IBIMR_proxy_id=
&SIGNON_CORRECT=
&SIGNON_CORRECT_ADMIN
&SIGNON_CRT_DOM_ADMIN
Wow, more parameters!


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Expert
posted Hide Post
Tech Support Techniques:

Redirect MR Developer users to a specific page after logon

How to set a custom login page and redirect to other page

I'm not sure that these techniques help that much, as they only specify some of the required parameters...


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Report This Post
Gold member
posted Hide Post
Thanks everyone.
I have hit a road block from the Admin group. There telling me the use of a URL that has UserID and Password is a security issue. Even if the user ID and Password are for a user that only has run access. Again thanks for the help.
 
Posts: 84 | Location: Tallahassee, Fl. | Registered: December 02, 2005Report This Post
Platinum Member
posted Hide Post
Mike,
That is not an issue :-). Add something like this under "Custom Settings" within the WebFOCUS Administration "Configuration Settings".
<IF> FOO.upper EQ "BAR" AND IBIMR_action EQ "MR_SIGNON"
IBIMR_user=MyUSERID
IBIMR_pass=MyPass
<ENDIF>


Then when you trigger the signon, just pass FOO=BAR and IBIMR_action=MR_SIGNON along with the request and it will default the values for these without having real userids/passwords in the URL.


WF 71.x, 76.x, 7701, 8.0 Beta OS: Linux, Win2k3, Win2k, Win2k8, WinXP


 
Posts: 203 | Registered: November 19, 2007Report This Post
Gold member
posted Hide Post
Thanks Dlogan, I pass this on the Admin group.
 
Posts: 84 | Location: Tallahassee, Fl. | Registered: December 02, 2005Report This Post
Expert
posted Hide Post
FOOBAR, toooo funnnnyyy!!!! Smiler


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Gold member
posted Hide Post
After installing fiddler. I noticed that when I execute the URL: [URL=http://dotscomrep1/ibi_apps/WFServlet?IBIMR_action=MR_SIGNON&IBIMR_user=userid &IBIMR_pass=password&IBIMR_random ]LoginMRE[/URL]

A lot of js is ran during the process. which the cookies are also created but when I execute the URL:[CODE] [URL=http://dotscomrep1/ibi_apps/WFServlet?IBIMR_action=MR_SIGNON&IBIMR_user=cnwfftp&IBIMR_pass=giggles&IBIMR_random=&SIGNON_CORRECT=web - page]LoginMRE redirect[/URL] I only see a HTTP request for the web page. None of the MRE login processes are recorded. I thought the url was supposed to log into mre. This does not seem to be the case unless I have missed something. Does anyone have any ideas?
 
Posts: 84 | Location: Tallahassee, Fl. | Registered: December 02, 2005Report This Post
Platinum Member
posted Hide Post
You should see the cookies created.

The SIGNON_CORRECT part of the URL is also designed to redirect you to a web page. As a result with the values you have there, I'm not sure if that is messing up the actual loading of the MR Applet.

If you leave that parameter out it should go straight into the MR Applet.

Thanks,
Doug Logan


WF 71.x, 76.x, 7701, 8.0 Beta OS: Linux, Win2k3, Win2k, Win2k8, WinXP


 
Posts: 203 | Registered: November 19, 2007Report This Post
Gold member
posted Hide Post
Yes If I leave off the SIGNON_CORRECT parameter it goes stright to the MRE Applet but when I include the parameter it just goes to the web page without doing anything else.
 
Posts: 84 | Location: Tallahassee, Fl. | Registered: December 02, 2005Report This Post
Gold member
posted Hide Post
Dlogan, I just had a thought. Must the web page that I use be on the same server as the MRE?
 
Posts: 84 | Location: Tallahassee, Fl. | Registered: December 02, 2005Report This Post
Platinum Member
posted Hide Post
It may appear its only going to the website, but you would find that a MR_COOKIE has been generated and a logon has happened.

The page you redirect to can be anywhere as long as you use a fully qualified name.

e.g. http://www.google.com

If you give a relative name, it will also redirect to the relative path.

If you want to confirm the logon has happened, go back to the ibi_apps welcome page after doing a redirect and check for a MR_COOKIE within the header of your requests on Fidder2.

Thanks,
Doug Logan


WF 71.x, 76.x, 7701, 8.0 Beta OS: Linux, Win2k3, Win2k, Win2k8, WinXP


 
Posts: 203 | Registered: November 19, 2007Report This Post
  Powered by Social Strata Page 1 2  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     dashboard:what is the exact form of a url to a .htm

Copyright © 1996-2020 Information Builders