Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] ReportCaster FTP to network drive?
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] ReportCaster FTP to network drive?
 Login/Join
 
Expert
posted
FTPing to network drive from ReportCaster should be simple.

Maybe this is a brain freeze or something. But, while I can email a report to an email address (showing that the RC job and report functionality is fine.), I cannot FTP it to a network drive. BTW: My id/pw are correct.

The FTP results is "Schedule ID: [job id], Job Description: [job name] Completed with errors/warnings unable to distribute to FTPtest.pdf \\this.net\folder1\folder2\folder3".

This message has been edited. Last edited by: <Kathryn Henning>,


   In FOCUS Since 1983 ~ from FOCUS to WebFOCUS.
   Most recent: 8204 Gen 48 in Test and Production.
 
Posts: 3043 | Location: Middle Tennessee [8204M Gen48 in Test&Prod] | Registered: February 23, 2005Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Is the WebFOCUS server having access to the network drive location?
The user id/pwd you mentioned are those the details used for schedule execution
or
Are those the details to access the destination?

Does the user id/pwd has write access to that location?


WebFOCUS - ver8201
[ReportingServers: Windows 64bit;
Client: tomcat and IIS on windows 2012
AppStudio

 
Posts: 103 | Location: Indianapolis | Registered: November 08, 2007Reply With QuoteReport This Post
Platinum Member
posted Hide Post
This may seem like an obvious question, but do you have an FTP server running on any of your machines?

If you turn on all traces you will see that ReportCaster tries to connect to an FTP server using FTP client commands. If there is no server then it fails.

If you do have an FTP server running, then look at the ReportCaster full log to see if it gives more information on why it fails. Otherwise run it again with traces enabled.


WebFOCUS 8.2.03 (8.2.06 in testing)
 
Posts: 241 | Location: Melbourne, Australia | Registered: February 07, 2007Reply With QuoteReport This Post
Expert
posted Hide Post
I'll check the logs to get the answers to your questions.

My desired destination is the shared network drive where my, and all other users have their, network drives. Perhaps I need the pw/id for the base network drive and not just my own (full path) id/pw?

Like I said, I'll check the logs...
 
Posts: 3043 | Location: Middle Tennessee [8204M Gen48 in Test&Prod] | Registered: February 23, 2005Reply With QuoteReport This Post
Gold member
posted Hide Post
hello, did you happen to find out what the issue was? i have a similar error where i'm trying to run a report and output is excel to a network share.

in the log is shows all is well except the distribution failed and i believe i might not have the right settings...


WebFocus 8.02, SQL Server 2008r2
 
Posts: 51 | Registered: November 30, 2012Reply With QuoteReport This Post
Platinum Member
posted Hide Post
We had similar issues.
In the end in our case it had to do with the user which was used for the WF reporter server (service). We had to change this from the system user to another user which could be provided the correct rights on the network share. By the way, the service seems only to run if the system user is used or exactly the same use which was used during WF installation.


WebFocus 8203M, iWay DataMigrator, Windows, DB2 Windows V10.5, MS SQL Server, Azure SQL, Hyperstage, ReportCaster
 
Posts: 154 | Registered: March 29, 2013Reply With QuoteReport This Post
Gold member
posted Hide Post
Hi Martin vK,

interesting, i have the user who WF was installed under as the user executing the schedule. When i edit my schedule i see that the distribution has the following fields:

Type:
- Distribution List
- Distribution File
- Single File <- selected
- Dynamic Distribution List

Name:
- Name of file

Directory
- E:\xxx (this directory exists on the WF server itself as well as the user has accessibility to the share itself)

In the error log everything checks out except this line:

BTP1010 The distribution failed: Connection refused: connect


WebFocus 8.02, SQL Server 2008r2
 
Posts: 51 | Registered: November 30, 2012Reply With QuoteReport This Post
Platinum Member
posted Hide Post
You write "i have the user who WF was installed under as the user executing the schedule", but is this also the user account which the SERVICE of WebFOCUS Server and WebFOCUS ReportCaster use to Log on? Please check your Services.
If this is okay, I suggest to put some traces on to get more information.


WebFocus 8203M, iWay DataMigrator, Windows, DB2 Windows V10.5, MS SQL Server, Azure SQL, Hyperstage, ReportCaster
 
Posts: 154 | Registered: March 29, 2013Reply With QuoteReport This Post
Member
posted Hide Post
Dull questions but are you fully qualifying the address rather than E:\ or something.
Second thing to try is to use a DOS NET USE command to map a drive from your webfocus side of things.


Developer Studio Release : 7.6.11
 
Posts: 21 | Location: TataSteel Strip Products UK , Port Talbot , South Wales | Registered: November 28, 2006Reply With QuoteReport This Post
Gold member
posted Hide Post
hi Martin/Madasabear,

Yes the account i am using is the the master account we used for WF install and is able to logon to the server and reportcaster.

I am also using the full address but i will look into DOS NET USE.

I'll keep working away at it thanks for the help so far!


WebFocus 8.02, SQL Server 2008r2
 
Posts: 51 | Registered: November 30, 2012Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] ReportCaster FTP to network drive?

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.