Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [solved]Oracle adapter
Go
New
Search
Notify
Tools
Reply
  
[solved]Oracle adapter
 Login/Join
 
Guru
posted
Hi,

I am trying to configure a connection using Oracle adapter 9.2.0.
When testing the connection i am getting the following error message:

FOC1261) PHYSICAL INTERFACE NOT FOUND FOR SUFFIX SQLORA. MODULE NAME : OR8PS92
(FOC1262) THE FOLLOWING NATIVE ERROR MESSAGE(S) CAPTURED :
(FOC1260) Loading D:\ibi\srv76\home\bin\or8ps92.dll: SearchPath: failed to find
OCI.dll
(FOC1263) THE CURRENT ENVIRONMENT VARIABLES FOR SUFFIX SQLORA ARE :
(FOC1260) NLS_LANG : EN
(FOC1400) SQLCODE IS -1 (HEX: FFFFFFFF)
(FOC1488) SQL INTERFACE HAS NOT BEEN INSTALLED OR COULD NOT BE INITIALIZED
(FOC1479) ERROR CONNECTING TO SQL DATABASE

Any idea about the cause?

Regards.

This message has been edited. Last edited by: Majid Jeddi,


WebFocus 7.6.5
AND WebLogic server as web server
sql2005 as database server
 
Posts: 273 | Location: Europe | Registered: May 31, 2007Reply With QuoteReport This Post
Guru
posted Hide Post
Hi,

This issue is solved. I had to install the Oracle client on the webfocus server and configure the service names.

Regards.


WebFocus 7.6.5
AND WebLogic server as web server
sql2005 as database server
 
Posts: 273 | Location: Europe | Registered: May 31, 2007Reply With QuoteReport This Post
Platinum Member
posted Hide Post
I have the same problem when trying to setup Oracle 10g in WebFOCUS dev studio local server. I already have Oracle client installed, created ORACLE_HOME varialbe and include the Oracle client folder in PATH variable.

What am I missing?


7.66 and 7.704
System: Windows / AIX / Linux
Output: Mostly HTML, with some PDF, Excel and Lotus(!)
 
Posts: 147 | Location: Toronto (GTA) | Registered: May 25, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Did you restart the local server after you added that environment variable?


WebFOCUS 8.1.03, Windows 7-64/2008-64, IBM DB2/400, Oracle 11g & RDB, MS SQL-Server 2005, SAP, PostgreSQL 11, Output: HTML, PDF, Excel 2010
: Member of User Group Benelux :
 
Posts: 1650 | Location: Enschede, Netherlands | Registered: August 12, 2010Reply With QuoteReport This Post
Member
posted Hide Post
Although the information provided is insufficient, here is one "option"

One of the reasons that can cause an SQLCODE IS -1 error (but without any native Oracle OCI message) is if you have a 64bits WebFOCUS Reporting server and have either no Oracle client installed or have only a 32bits client installed.

You should check the version of the reporting server (from the Web Console in the Help drop down menu)

Then the best thing is to open a case to InfoResponse Online Support Web Site.
 
Posts: 11 | Location: Information Builders France | Registered: May 22, 2003Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [solved]Oracle adapter

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.