Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Task Error: While Scheduling the Reports [Solved]

Read-Only Read-Only Topic
Go
Search
Notify
Tools
Task Error: While Scheduling the Reports [Solved]
 Login/Join
 
Gold member
posted
HI All,
I am trying to execute the schedule from MRE from Integration Layer. but I am getting following error....


Task error: WARNING: SORTING ON A COMPUTED FIELD % ROWCNT
No report to distribute


When I run the Schedules as a standalone it is getting properly scheduled without any error.
Also I am running the report then also it doesnot give any error.
But when I run the schedules from the Integration Layer....Then this error occurs....

Does someone observed this behaviour? Is this any enviornment specific...??

Any suggestions/ideas would be highly appreciated....
Thanks.

This message has been edited. Last edited by: Anmol,


WebFocus7.6.2, WebFocus 7.1.1,Windows
HTML, PDF and Excel
 
Posts: 71 | Registered: June 30, 2009Report This Post
Expert
posted Hide Post
When sorting on a computed field the syntax must look like this:
BY TOTAL computed_field

It may be that your error is hidden in the other environments. You might want to do a view source to see if that is the case.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Report This Post
Gold member
posted Hide Post
Thanks Ginny,
I was not able to view the source as it was Report caster log which was not in Debug mode.
I used "BY TOTAL computed_field"
and then tried to run the schedule in debug mode, which works fine...

This resolves my problem....Kudos to you Ginny....

But one question am not able to understood that that why this warning not there in EDASERVE or when we run this Report normally....

I have this report without "BY TOTAL computed_field" like only "BY computed_field"
Though it is working fine...

Why is this warning in MRE only and only Scheduled report from Integration Layer.?
Is this bug?
do u have any Idea....
All suggestions would be helpful...
thanks...!


WebFocus7.6.2, WebFocus 7.1.1,Windows
HTML, PDF and Excel
 
Posts: 71 | Registered: June 30, 2009Report This Post
Expert
posted Hide Post
The error was probably there when you ran from EDASERVE. Either have your output in HTML and do a view source OR turn the Message Viewer on.

At any rate, you should follow this rule in case IBI tightens the code in a later release and doesn't allow you to get away with it.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Report This Post
Gold member
posted Hide Post
Yes Ginny, You are correct......

I also get that warning in when i ran report from EDASERVE, i have seen the warning at the last in source code.....

This seems that when we schedule the report this warning doesn't allow the report to distribute in the libray.....

Thanks Much Ginny..... Smiler
Your help Appreciates.......!!


WebFocus7.6.2, WebFocus 7.1.1,Windows
HTML, PDF and Excel
 
Posts: 71 | Registered: June 30, 2009Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Task Error: While Scheduling the Reports [Solved]

Copyright © 1996-2020 Information Builders