Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED]EXL07 output gives HTTP 500 error
Go
New
Search
Notify
Tools
Reply
  
[SOLVED]EXL07 output gives HTTP 500 error
 Login/Join
 
Platinum Member
posted
Hi,

I am outputting for a long time already to EXL07 but yesterday I ran into a strange problem.
I have a simple table request providing 315K rows output, which is working fine with EXL2K output, but not with EXL07 output.
TABLE FILE HLDCTGVGS
PRINT *
ON TABLE HOLD AS 'G:\DATA\CTG\MARTIN.XLS' FORMAT EXL2K
END
-RUN
-TYPE &LINES
TABLE FILE HLDCTGVGS
PRINT *
ON TABLE HOLD AS 'G:\DATA\CTG\MARTIN.XLSX' FORMAT EXL07
END
-RUN
-TYPE &LINES


WebFOCUS does not give any error and both &LINES give same number of 315349 lines.
The resulting XLS is fine, but the XLSX is only 660 bytes large.

When I open the 660 bytes XLSX with Notepad++it contains following:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
   "http://www.w3.org/TR/html4/loose.dtd">
<HTML>
<HEAD>
<STYLE type="text/css">
	.bdymre { background-image:url('/ibi_html/workbnch/bdy_bgw.gif'); background-repeat:no-repeat}
</STYLE>
	<TITLE>Application Server Error Page</TITLE>
</HEAD>
<body BGCOLOR="#FFFFFF" class="bdymre">
	[b]<FONT SIZE="-1" FACE="Arial">An HTTP 500 error has been returned while processing the web components.  The application server log contains information on why this error has occurred.  Contact your application administrator or your software vendor support center for further assistance.</FONT>[/b]
</BODY>
</HTML>

Has anyone encountered this before and can explain to me what the problem is? It refers to the "application server log". Where do I find this for finding more information?

I am outputting in this same environment frequently without any problem to EXL07, so I do not understand why this one is not working.

This message has been edited. Last edited by: Martin vK,


WebFocus 8203M, iWay DataMigrator, Windows, DB2 Windows V10.5, MS SQL Server, Azure SQL, Hyperstage, ReportCaster
 
Posts: 153 | Registered: March 29, 2013Reply With QuoteReport This Post
Guru
posted Hide Post
Could you check the edaprint.log? I once had a similar issue and it showed an out of memory error in the logs.

Reason xlsx needs more momory is because it's doing a compression of the data.


Test: WF 8.2
Prod: WF 8.2
DB: Progress, REST, IBM UniVerse/UniData, SQLServer, MySQL, PostgreSQL, Oracle, Greenplum, Athena.
 
Posts: 393 | Location: Europe | Registered: February 05, 2007Reply With QuoteReport This Post
Platinum Member
posted Hide Post
http://forums.informationbuild...1057331/m/2897030406


WF Production :- WF:8.0.0.4, 8.1.05 App-studio/Developer Studio(8.1.x) ,
8.2.0.1M , 8.2.0.2 (App-Studio8.2.x),
InfoAssist/+, InfoDiscovery
Output format:-AHTML, PDF, Excel, HTML
Platform:-Windows 7, 8,10
 
Posts: 186 | Location: Infobuild India | Registered: August 28, 2015Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Hi Frans,

I did check the edaprint.log, but it is not showing any error. I also checked the Tomcat log files (jakarta/stderr/stdout) and that is not showing anything either.

I found an old FP post of 2010 which refers to java app server log and increasing java memory size.
I am not sure where exactly to look....
I am now looking at the Java Services in the Webconsole. I do note that the agent taking care of the request indicates a memory usage of 1GB, and I do see that at the Java Services in the JVM Settings where is a initial and maximum Java Heap Size of 1024MB, so this might be indeed the limit.
After increasing this to 2048MB and restarting, the job still gives http 500, so this is not helping or still not enough.

It seems EXL07 just takes too much memory when used with large files, although I do not consider this large yet....
With small reports EXL07 is okay, but with larger data sets it seems we have to stick with EXL2K.


WebFocus 8203M, iWay DataMigrator, Windows, DB2 Windows V10.5, MS SQL Server, Azure SQL, Hyperstage, ReportCaster
 
Posts: 153 | Registered: March 29, 2013Reply With QuoteReport This Post
Guru
posted Hide Post
Hi Martin,

Could it be that there are some special charachters in the endresult? I can remember url's could also cause issues.

You could also consider to upgrade to 8.2...lot's of stuf has been improved with exl07 exports.


Test: WF 8.2
Prod: WF 8.2
DB: Progress, REST, IBM UniVerse/UniData, SQLServer, MySQL, PostgreSQL, Oracle, Greenplum, Athena.
 
Posts: 393 | Location: Europe | Registered: February 05, 2007Reply With QuoteReport This Post
Virtuoso
posted Hide Post
What version of WebFOCUS are you using?
What happens if you switch to PCHOLD FORMAT XLS instead of HOLD?


WebFOCUS 8206, Unix, Windows
 
Posts: 1660 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Platinum Member
posted Hide Post
I finally found and solved the problem.
It had to do with the EXCELSERVURL setting. We had this pointing to the WebFOCUS client, which works fine with a web application or ReportCaster output going through the WF client. But as this was a hold file stored on a data disk on the Reporting Server (separate server from WF client) this seemed to cause the problem. With small files no problem, but getting a bit larger, it becomes very slow and reaching this limit.

By SET EXCELSERVURL = '' for these cases I have solved this, and I do get the xlsx again, even for much larger files.

Thanks for all your questions and remarks.


WebFocus 8203M, iWay DataMigrator, Windows, DB2 Windows V10.5, MS SQL Server, Azure SQL, Hyperstage, ReportCaster
 
Posts: 153 | Registered: March 29, 2013Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED]EXL07 output gives HTTP 500 error

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.