Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Problem with DATECVT after migrating to wf 5.2.6 from 5.2.1
Go
New
Search
Notify
Tools
Reply
  
Problem with DATECVT after migrating to wf 5.2.6 from 5.2.1
 Login/Join
 
<kj>
posted
Has any one experienced this problem when migrated from webfocus 5.2.1 to 5.2.6 on Win 2k. This is working fine in 5.2.1 and not in 5.2.6.
I am getting an error
(FOC36355) INVALID TYPE OF ARGUMENT #2 FOR USER FUNCTION DATECVT
when it is run in 5.2.1. Is there a change in how the date functions are executed?

DEFINE FILE CAR
GMTNOW/HMDYYI = HGETC(8,'HMDYYI');
GMTNOWA8/A8 = HCNVRT(GMTNOW, '(H17)', 17, 'A8');
GMTNOWI8/I8 = EDIT(GMTNOWA8);
GMTNOWYYMD/YYMD = DATECVT(GMTNOWI8,'I8YYMD','YYMD');
END
TABLE FILE CAR
PRINT CAR MODEL SEATS GMTNOWYYMD
BY COUNTRY
END


thanks,
kj
 
Reply With QuoteReport This Post
Silver Member
posted Hide Post
Exactly. There is new functionality that checks arguments when calling subroutines.
To turn it off
SET USERFCHK=OFF.
To fix the original problem change the format of
GMTNOWI8/I8 = EDIT(GMTNOWA8);
to
GMTNOWI8/I8YYMD = EDIT(GMTNOWA8);
 
Posts: 34 | Location: 2 Penn Plaza | Registered: July 29, 2004Reply With QuoteReport This Post
<kj>
posted
Thanks BIGBMN. That worked.

Also if there is no ELSE for IF, it throws up an error. Does any one has experienced with any other problems while migrating to 5.2.6?

kj
 
Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Problem with DATECVT after migrating to wf 5.2.6 from 5.2.1

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.