Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] upgrade to 8.1.03 or 8.2?
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] upgrade to 8.1.03 or 8.2?
 Login/Join
 
Silver Member
posted
Has anyone that has upgraded to version 8.0.x subsequently upgraded to 8.1.03? There are some new portal features that we want to take advantage of, but are wondering how much of an effort it is to upgrade from 8.0.0.8 to 8.1.03. Can the upgrade be done in place? Are there any gotcha's? Are there any changes to the underlying repository tables? What are the changes if we were to wait and go with 8.2? Same questions apply for this as well. Gotchas, in place, etc.

Thanks for your time.

This message has been edited. Last edited by: <Kathryn Henning>,


8.0.0.8
Linux/windows
 
Posts: 36 | Registered: October 24, 2012Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Hi Kris,

I can't answer all your question, but in my yesterday User Group, I've been told to wait for 8.2 that will be released after Summit. The new features and correction made in 8.1.04 doesn't worth the update since 8.2 is near and some feature of 8.1.04 needs special java script that will be embedded in 8.2


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2394 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Reply With QuoteReport This Post
Silver Member
posted Hide Post
Thanks Martin, that is good to know.


8.0.0.8
Linux/windows
 
Posts: 36 | Registered: October 24, 2012Reply With QuoteReport This Post
Master
posted Hide Post
Yea, we talk to IBI, a few times a week and they told us to hold off for 8.2 in Jun. 8.1 has some issues.



- FOCUS Man, just FOCUS!
-----------------------------
Product: WebFOCUS
Version: 8.1.04
Server: Windows 2008 Server
 
Posts: 578 | Registered: October 01, 2014Reply With QuoteReport This Post
Platinum Member
posted Hide Post
We were going from 7.7.0.5 to 8.1.03. While the upgrade is in flight, we are now switching to 8.2. There are fewer issues, but still too many for me to list here while we are working on it. IBI has been pretty focused on helping us through this. It does feel like we are beta testing, but we are getting there.


WebFOCUS 7.7.05 (Someday 8)
Windows 7, All Outputs
In Focus since 1983.
 
Posts: 103 | Registered: April 27, 2011Reply With QuoteReport This Post
Expert
posted Hide Post
quote:
8.1 has some issues


Hmmm, just like 8.0.* then.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
We've just recently went from 8009 to 8104 and RS8.1M with a full reinstall and we've had issues with 8.0 repos, etc. not working with data correctly and other things the admin guy is working out. 8.1 works for the most part. It just goes downhill when you try to import 8.0 app domains into an 8.1 WF environment. Birds hit the fan when your 8.0 app files (now in the 8.1 repo) request joined data fields from a clustered synonym. The fields aren't recognized for some reason. A guy from IBI told us we needed to convert the 8.0 repo, portals, etc. manually with some .bat file that isn't even where the online docs say it should be. So our 8.0 app is junk till we can figure out how to convert our files to the new 8.1 architecture. That, or we rewrite it all in a newly created app domain. ...not! Anyone else here ever have issues with apps not recognizing fields after upgrading to a newer version?


8.2.02M (production), 8.2.02M (test), Windows 10, all outputs.
 
Posts: 1119 | Location: USA | Registered: January 27, 2015Reply With QuoteReport This Post
Platinum Member
posted Hide Post
I thought I had clarified my mistake, but I guess I didn't post it. It has been a bit hectic here. We are going from 7.7.0.5 to 8.1.0.3 and not to 8.2 as I had indicated. Still an interesting journey. We have found we have to do a lot of rebinding of variables in HTML Composer if that is what CoolGuys question is about.


WebFOCUS 7.7.05 (Someday 8)
Windows 7, All Outputs
In Focus since 1983.
 
Posts: 103 | Registered: April 27, 2011Reply With QuoteReport This Post
Virtuoso
posted Hide Post
So, I figured out that we had accidentally created 2 of the same synonym in different app directories. Got rid of the one that wasn't supposed to be there, rechecked app paths, and now the data works again! All fixed! :-)


8.2.02M (production), 8.2.02M (test), Windows 10, all outputs.
 
Posts: 1119 | Location: USA | Registered: January 27, 2015Reply With QuoteReport This Post
Silver Member
posted Hide Post
Sorry, I haven't responded earlier, I've been out of the office. Thanks for everyone's input. All good things to know. CoolGuy, it is good to know that you found the problem and it wasn't something complete out of whack with 8104.

Thanks again everybody.


8.0.0.8
Linux/windows
 
Posts: 36 | Registered: October 24, 2012Reply With QuoteReport This Post
Member
posted Hide Post
Kris:

We are planning to upgrade from 8008 to 8104 as well. At summit this year the expert room recommended I follow these steps (see link below).

http://infocenter.informationb...source%2Ftopic26.htm

I didn't do the conversion they describe at first but I think I was able to do it after the fact. This describes the procedure for doing that.

http://infocenter.informationb...source%2Ftopic37.htm

The roadblock we currently have is I cannot open the reporting server console due to a 403 - Forbidden error.
I need to install the 8104 application studio so I can modify HTML pages again.

It doesn't seem too bad. Have you had a chance to do your upgrade yet?


WebFocus 8008,Server: Ubuntu Linux, Output: html/excel/pdf
 
Posts: 20 | Registered: March 03, 2015Reply With QuoteReport This Post
Platinum Member
posted Hide Post
We did the upgrade from 8.0.0.9 to 8.1.04 and it went smooth.


8.2.06
Windows, All Formats
 
Posts: 183 | Registered: December 27, 2013Reply With QuoteReport This Post
Silver Member
posted Hide Post
I heard at Summit to wait until 8.2 rather than upgrade to 8.1 now (if on 8.0), but I never got the reason why. Does anyone know why we should wait?

Thank you,

Edit: updated signature - we are currently on 8.0.09.


WF 8.1.05 on Windows machines
Backend: Informix, SQL and Oracle databases
 
Posts: 38 | Location: Houston, Texas | Registered: May 01, 2008Reply With QuoteReport This Post
Gold member
posted Hide Post
Hi Emily

I know that in 8105 and 8200 that App Studio is going to be much faster, Performance of the tool is being rewritten and will be better.

Thanks Barry


WebFOCUS 8103, Windows, App Studio
 
Posts: 84 | Location: NYC | Registered: November 13, 2008Reply With QuoteReport This Post
Gold member
posted Hide Post
We just upgraded from 8.0.08 to 8.1.04 and have been very happy with the updates. The new portal features are great, and 8.1.04 is far less buggy than 8.0.08. We felt like we were developing one handed in 8.0.08, so anything was an improvement from that.


WebFOCUS 8.2.03
z/OS
 
Posts: 67 | Registered: May 20, 2013Reply With QuoteReport This Post
Master
posted Hide Post
We are 8.1.04 in Dev, 8.0.07 in prod, 8.0.09 in preprod, but we are waiting on 8.2, which resolves a lot of issues still lingering in 8.1.



- FOCUS Man, just FOCUS!
-----------------------------
Product: WebFOCUS
Version: 8.1.04
Server: Windows 2008 Server
 
Posts: 578 | Registered: October 01, 2014Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] upgrade to 8.1.03 or 8.2?

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.