Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Drill down on an image [code]

Read-Only Read-Only Topic
Go
Search
Notify
Tools
Drill down on an image [code]
 Login/Join
 
Silver Member
posted
Hello Folks,
I have two images on my report. one is an excel icon and other is a pdf icon. These reports are drilldowns to run the same report in excel or pdf format. I have the report written below. After i moved the postition of the images to the location i wanted. There always exists a small line or a dot which is again always a link. Can u please help me with this..


-SET &ECHO=ALL;

TABLE FILE CAR
PRINT
'CAR.ORIGIN.COUNTRY'
'CAR.COMP.CAR'
'CAR.CARREC.MODEL'
'CAR.BODY.BODYTYPE'
'CAR.BODY.SEATS'
'CAR.BODY.DEALER_COST'
'CAR.BODY.RETAIL_COST'
'CAR.BODY.SALES'
'CAR.SPECS.LENGTH'
'CAR.SPECS.WIDTH'
'CAR.SPECS.HEIGHT'
'CAR.SPECS.WEIGHT'
'CAR.SPECS.WHEELBASE'
'CAR.SPECS.FUEL_CAP'
'CAR.SPECS.BHP'
'CAR.SPECS.RPM'
'CAR.SPECS.MPG'
'CAR.SPECS.ACCEL'
'CAR.WARANT.WARRANTY'
'CAR.EQUIP.STANDARD'
HEADING
" "
" "
ON TABLE NOTOTAL
ON TABLE PCHOLD FORMAT HTML
ON TABLE SET HTMLCSS ON
ON TABLE SET STYLE *
UNITS=IN,
SQUEEZE=ON,
ORIENTATION=PORTRAIT,
$
TYPE=REPORT,
GRID=OFF,
FONT='TIMES NEW ROMAN',
SIZE=10,
$
TYPE=REPORT,
IMAGE=APP/MS_EXCEL_ICON.GIF,
POSITION=(+5.000000 +0.000000),
TARGET='_blank',
FOCEXEC=app/carexl.fex,
$
TYPE=REPORT,
IMAGE=app/pdf_icon.gif,
POSITION=(+5.500000 +0.000000),
TARGET='_blank',
FOCEXEC=app/carpdf.fex,
$
ENDSTYLE
END
-EXIT


7.7.02, sql server
Windows
all output (Excel, HTML, PDF)
 
Posts: 38 | Registered: April 26, 2010Report This Post
Expert
posted Hide Post
You can either change the POSITION from relative, (+nnn +nnn) to absolute (nnn nnn) or change the TYPE=REPORT to TYPE=HEADING or something else, for the images.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Silver Member
posted Hide Post
After changing the position.
On the left top corner there exists a small dot or a blue line which also acts as a link.

How do i get rid of that.

If we actually run the report you can see the small dot or a small blue line...


7.7.02, sql server
Windows
all output (Excel, HTML, PDF)
 
Posts: 38 | Registered: April 26, 2010Report This Post
Expert
posted Hide Post
what does the code look like now ?


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Silver Member
posted Hide Post
I replaced TYPE=HEADING instead of TYPE=REPORT and this solved the problem. Now i dont see that dot. Thank you very much.

Is there a reason why this dot appears when we use TYPE=REPORT,


7.7.02, sql server
Windows
all output (Excel, HTML, PDF)
 
Posts: 38 | Registered: April 26, 2010Report This Post
Expert
posted Hide Post
When you made the change with TYPE=REPORT, did you remove the + from the position ?


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Drill down on an image [code]

Copyright © 1996-2020 Information Builders