Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CASE-OPENED] Agents are crashed

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CASE-OPENED] Agents are crashed
 Login/Join
 
Gold member
posted
When I run one of my .fex file, I am getting message called “agents are crashed”. Then I went back to my report server and looked at the data service agents, all agents state is “crashed”, Did anybody having any idea, why my agents are crashed?
By the way I am new to this forum and the product.
Any suggestions will be appreciated.

This message has been edited. Last edited by: Kerry,


WebFocus 8202M
APP Studio
Info assist
Report caster
Portals
Maintain
EXcel,PDF,HTML,Active Reports
 
Posts: 82 | Location: MD | Registered: May 14, 2010Report This Post
Gold member
posted Hide Post
If you have
-SET &ECHO = ALL;
this will crash if a lot of lines of code are being generated. Comment/delete this line of code.


WF 8.2.01M
8.2.01M Reporting Server
Windows 2012 Srvr R2
PDF,Excel, HTML
Graphs - a lot of graphs
 
Posts: 60 | Location: Atlanta, GA | Registered: October 30, 2003Report This Post
Virtuoso
posted Hide Post
Probably means you've got an error in the fex - not necessarily a syntax error, but something that the server doesn't like. Maybe try SET XRETRIEVAL=OFF and include a -SET &ECHO=ALL; to check your code.

And you probably want to clean up those crashed agents.

This message has been edited. Last edited by: Darin Lee,


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Report This Post
Expert
posted Hide Post
quote:
Maybe try SEX XRETRIEVAL=OFF
... and you work in Utah Darin? Wink

I'm surprised that the censure fairy didn't hit that one!

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5694 | Location: United Kingdom | Registered: April 08, 2004Report This Post
Expert
posted Hide Post
Another option is to put a -EXIT in your program, at first eanrly in the program, then on each successfull run moving it down then code till the agent crashes.

This will give you an idea where it is failing.

The next step is finding out the problem, thats the difficult part.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Virtuoso
posted Hide Post
I'm surprised too. They must have know what I MEANT to say (Tony!). That would be SET XRETRIEVAL=OFF.


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Report This Post
Gold member
posted Hide Post
Hi, this issue was not resolved. Ours is brand new installation (7.6.10, 64bit) and this issue was escalated to the customer service. We are getting this issue right after Resource analyzer and resource governor installation.

Right now product management is looking at this issue.


WebFocus 8202M
APP Studio
Info assist
Report caster
Portals
Maintain
EXcel,PDF,HTML,Active Reports
 
Posts: 82 | Location: MD | Registered: May 14, 2010Report This Post
Expert
posted Hide Post
Well if its happening after an installation of RA and RG, then thats the area to look at first.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Member
posted Hide Post
This item was reported to IBI over a week ago. IBI has replicated the problem, identified the issue with RA and RG with connection pooling on running 64bit on 2008 and is in the process of testing a fix for this.


WebFOCUS 8.1.0.5m
 
Posts: 26 | Registered: October 09, 2007Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CASE-OPENED] Agents are crashed

Copyright © 1996-2020 Information Builders