Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED]is there a cure for ECHO=ALL mistake?
Go
New
Search
Notify
Tools
Reply
  
[SOLVED]is there a cure for ECHO=ALL mistake?
 Login/Join
 
Guru
posted
SO we have a application where developers pushed lots of fexes to prod with the dreading line ECHO=ALL; I'm wondering is there a global setting to turn it off? Unfortunately its a line in every fex inside each reportcaster job (over 100 or so). Definitely a bad idea to have that in prod but, I figured I'll ask here if any of you guys handled it differently?

Thanks in advance.

This message has been edited. Last edited by: vaayu,


-********************
Sandbox: 8206.10
Dev: 8201M
Prod:8009
-********************
 
Posts: 279 | Location: Houston,TX | Registered: June 11, 2004Reply With QuoteReport This Post
Expert
posted Hide Post
Probably not.

There are some options to turn everything off, but not sure of the results. and wouldn't recommend it.

SET EMGSRV=OFF
SET MSG=OFF

I would suggest getting your developers to put in a line like:

-DEFAULTH &DEBUG_MODE = OFF
-SET &ECHO=&DEBUG_MODE;

Then it can be set in a profile or as a parameter.

We have put in place a fex checker on release to another environment to scan for -SET &ECHO and flag it as an issue.

You may need to add this sort of thing to your release process.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6281 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Virtuoso
posted Hide Post
I wonder if you can use LET command to fake it out.


WebFOCUS 8206, Unix, Windows
 
Posts: 1853 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Expert
posted Hide Post
quote:
use LET command to fake it out.

I suspect not, as it only works on FOCUS commands not dialog manager


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6281 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Master
posted Hide Post
Check out theses docs

If you set the ECHO to NONE as a pre-process, that will prevent procedure code from being displayed (echoed). Once the value of &ECHO has been set to NONE, it cannot be changed during the session or connection.


Hallway

 
Prod: 8202M1
Test: 8202M4
Repository:
 
OS:
 
Outputs:
 
 
 
 
 
Posts: 608 | Location: Salt Lake City, UT, USA | Registered: November 18, 2015Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Wow that's outstanding! I didn't know this little feature exists. Very nice indeed. Thanks Hallway.


WebFOCUS 8206, Unix, Windows
 
Posts: 1853 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Expert
posted Hide Post
What version did this come in on ?

Just checked 8.1.04 and its in the documentation.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6281 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Guru
posted Hide Post
Thank you Hallway, that seemed to have worked for what we're doing. Appreciate your help!!
quote:
Originally posted by Hallway:
Check out theses docs

If you set the ECHO to NONE as a pre-process, that will prevent procedure code from being displayed (echoed). Once the value of &ECHO has been set to NONE, it cannot be changed during the session or connection.


-********************
Sandbox: 8206.10
Dev: 8201M
Prod:8009
-********************
 
Posts: 279 | Location: Houston,TX | Registered: June 11, 2004Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Nice Thread


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 1974 | Location: Customer Support | Registered: April 12, 2005Reply With QuoteReport This Post
Master
posted Hide Post
quote:
What version did this come in on


It looks like 7.7 is when it came out.

I found it in the 7.7 docs:

...wf77appslang/source/test_debug.htm

But not in the 7.6.1 docs:

...wf761appslang/source/test_debug.htm

This message has been edited. Last edited by: Hallway,


Hallway

 
Prod: 8202M1
Test: 8202M4
Repository:
 
OS:
 
Outputs:
 
 
 
 
 
Posts: 608 | Location: Salt Lake City, UT, USA | Registered: November 18, 2015Reply With QuoteReport This Post
Expert
posted Hide Post
Wow, need to read the documentation more often.....


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6281 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Master
posted Hide Post
quote:
Originally posted by Waz:
Wow, need to read the documentation more often.....


I actually found the ECHO setting by helper fex that I have that reports all of the available SETs and their current/available values.
  TABLE FILE sysset
PRINT  
    VALUE AS 'Available,Values'   
    SETMAXLEN AS 'Max,Length/,Value'
    SETFPROMPT AS 'From,PROMPT'
    SETFTAB AS 'From,TABLE'
    SETFPARMS AS 'From,PARAMS'
    VALDESC
    IS_DEFAULT
BY SETNAME
BY SETDESC
BY SERVDESC
BY SETVALTYPE
BY CURR_VALUE
WHERE SETNAME EQ &SETNAME.(OR(FIND SETNAME IN sysset |FORMAT=A64)).Select SET value.;
ON TABLE SET PAGE-NUM OFF
ON TABLE SET STYLE *
INCLUDE=IBFS:/FILE/IBI_HTML_DIR/ibi_themes/flat.sty,$
TYPE=REPORT, LINES-PER-PAGE=UNLIMITED, TITLETEXT='WebFOCUS Sets', $
ENDSTYLE
END


There are other system tables that you can query as well. Docs here: https://webfocusinfocenter.inf..._lang/source/fmi.htm


Hallway

 
Prod: 8202M1
Test: 8202M4
Repository:
 
OS:
 
Outputs:
 
 
 
 
 
Posts: 608 | Location: Salt Lake City, UT, USA | Registered: November 18, 2015Reply With QuoteReport This Post
Expert
posted Hide Post
Yes, one of those gems that can be easily forgotten.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6281 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Master
posted Hide Post
If you want to turn it completely off in production, put -SET &ECHO=NONE; in the edasprof.


In FOCUS since 1985. Prod WF 8.0.08 (z90/Suse Linux) DB (Oracle 11g), Self Serv, Report Caster, WebServer Intel/Linux.
 
Posts: 958 | Location: Oklahoma City | Registered: October 27, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
I came across this while checking something about "-PROMPT".

BUT, Nice Suggestion John, to "turn it completely off in production, put -SET &ECHO=NONE; in the edasprof." Smiler




   In FOCUS Since 1983 ~ from FOCUS to WebFOCUS.
   Current: WebFOCUS Administrator at FIS Worldpay | 8204, 8206
 
Posts: 3112 | Location: Tennessee, Nashville area | Registered: February 23, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED]is there a cure for ECHO=ALL mistake?

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.