Focal Point
[SOLVED] HTML Composer Lost Files

This topic can be found at:

November 22, 2010, 08:53 AM
Don Garland
[SOLVED] HTML Composer Lost Files
Has anyone had a problem with HTML Composer losing the HTML file on save? I create or modify an file, adding objects, vars etc., saving along the way, I close the file normally and suddenly my file is 0 bytes. I open it back up and it's blank. This is a very frustrating and expensive problem.

Any idea what it could be and what can I do different to keep this from happening?

I'm running 7611 (GEN:02252010) on an XP laptop w/2gig of mem lots of HD space on a 100gig Cisco network with Win2K Servers.


This message has been edited. Last edited by: Kerry,
November 22, 2010, 10:13 AM

Yes I have faced this issue before, I think it occurs because we have opened the same HTML file more than once in HTML composer....
If we modify the file and save it will not save as the the same file is opened at other place..

While doing modification ensure that the file is opened at a only single instance, this will not cause the problem........
Please let us know how it goes..


WebFocus7.6.2, WebFocus 7.1.1,Windows
HTML, PDF and Excel
November 22, 2010, 10:25 AM
We have seen similar issues with fex files.

Originally we had the problem because of a full file-system, but later on we found that some files got garbled half-way or got their contents replaced with those of a different file!

We haven't seen the issue since installing HotFix 4 for Dev Studio, so that seems to have fixed it (*knocks on wood*).

So, check that your file-system has sufficient space left and that you're up-to-date.

WebFOCUS 8.1.03, Windows 7-64/2008-64, IBM DB2/400, Oracle 11g & RDB, MS SQL-Server 2005, SAP, PostgreSQL 11, Output: HTML, PDF, Excel 2010
: Member of User Group Benelux :
November 22, 2010, 03:47 PM
Don Garland
I've been very careful today as I need to deliver this interface before the break. A few times I notice that controls did appear when I ran the Launch page (HTML). I went back to Composer, focused on the object and it came back. Very weird. But while I was concentrating on not losing my HTML launch page, I lost the fex file. See the problem is, you have no idea that you've lost it. you close it and it's gone, all of it. I just lost everything since lunch and I'm about to lose that. I'll check disk space and find out what hotfix we're on. Thanks.
November 23, 2010, 08:02 AM
Don Garland
Last night it hit me that these problems started when I added a Tabbed interface to the application. Not sure why that would be a problem but I have a feeling that's the root of it.
January 04, 2011, 08:53 AM
Don Garland
We applied HotFix 4 and it did not make a difference in this behavior. I have been working with this issue to try to better understand it and one of our Developers has a case open.

Also, I removed the tabbed interface and it still a problem. For both the HTML launch page and the supporting FEX file.

I suspect that there is a limit to how much can be successfully saved every time. The application I'm working with has over 1200 lines of code.

I have a mapped drive to the app folder and I watch the save process and I see random zero byte files. As long as I don't close the WF Editor while the file is zero byte, I don't lose it. I just hit save again, until it actually saves the contents (has a file size GT 0). Then its safe to close it up.

WebFOCUS Administrator @ Worldpay FIS
PROD/DEV/TEST: 8204, SANDBOX: 8206 soon - BIP, Reportcaster, Resource Manager, EUM, HyperStage soon, DB: HIVE,Oracle,MSSQL
January 04, 2011, 12:40 PM
Don, Both the HTML composer and the PDF COMPOUND document composer.
Display some very strange behaviour in 7.6.10 thru 7.7.01.

Losing content (part or All), undoing changes as if it was restoring a cached version
(even after the server has been rebooted) and most irritating of all suddenly going into a loop
while loading and turning a 400 line procedure into a multi gig procedure (only stopped by killing

The 0 byte / short file situation is often caused by network issues because of the way
Dev Studio does its write back or because of Application server issues (Tomcat).

I suspect that Tomcat/java is probably the root cause.

Are you running the supported versions of both for your version of WF/Dev Studio?

The java version in particular can be a serious issue.

The fact that SUN is now owned by Oracle simply means that they are even more prone
to creating problems that when SUN was independant.