Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Consuming WebService from Webfocus
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Consuming WebService from Webfocus
 Login/Join
 
Silver Member
posted
I am trying to consume a webservice from webfocus. While creating synonym for WSDL getting error message "FOC44563: Error in parsing WSDL".

Although i am able to consume the same webservice from SoapUI.

Can anyone help to understand what is the reason for FOC44563
I just want to add that WSDL i am using is having import statements for xsd schema. So does Webfocus support the import?

Regards,
Dharma

This message has been edited. Last edited by: Kerry,


dharma
------------------
WF v 7.1.1
OS - Win XP
Output: PDF, EXL2K
 
Posts: 41 | Location: Boston | Registered: August 17, 2005Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Not sure what the error is, but if the web service is publicly available, you can provide it for us and we'll give it a shot.

What release of WebFOCUS are you using?
 
Posts: 140 | Registered: May 02, 2007Reply With QuoteReport This Post
Guru
posted Hide Post
Hi,

Are you able to get a result when you run the webservice URL in Internet Explorer?.

Majid.


WebFocus 7.6.5
AND WebLogic server as web server
sql2005 as database server
 
Posts: 273 | Location: Europe | Registered: May 31, 2007Reply With QuoteReport This Post
Silver Member
posted Hide Post
We are using 7.1.4 version of Webfocus. This webservice is not available in public but can send WSDL and associated xsd files and if anyone of you can create synonym then it will be immense help.

We are able to get result on internet explorer if gives URL of WSDL


dharma
------------------
WF v 7.1.1
OS - Win XP
Output: PDF, EXL2K
 
Posts: 41 | Location: Boston | Registered: August 17, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
I may be mistaken, but last I heard, the ability to consume a web service (and automatically generate a synonym from the WSLD) within WebFOCUS required an additional adapter license. You may want to check with your sales rep before going there.


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Reply With QuoteReport This Post
Silver Member
posted Hide Post
My organization is having license to use adapter for Webservices


dharma
------------------
WF v 7.1.1
OS - Win XP
Output: PDF, EXL2K
 
Posts: 41 | Location: Boston | Registered: August 17, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
If you already have the license, and the adapter is configured properly,then the synonym creation from the WSDL if pretty straightforward. It is all documented very well in the Data Administrators guide under "Using the Adapter for Webservices." The document includes extensive descriptions with examples of WSDL files, and descriptions of XSD data types and mappings.

It also includes direction for configuration of the adapter, in case that isn't quite set up correctly.

Having someone else create your metadata isn't going to solve your problem moving forward. If it doesn't work as documented (which has been know to happen occasionally), you probablly need to open a case directly with tech support.


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Reply With QuoteReport This Post
Platinum Member
posted Hide Post
In 7.1.3, we added support for Importing of Schema.
I do remember that we did make a bug fix in 7.6.4 to fix a problem on how
the Import was defined in the WSDL. I might be able to give you a workaround
for your release if I saw the WSDL file.
Please open up a Hottrack case and upload the WSDL file you are having problems with.
We will get you going.
 
Posts: 218 | Location: New York | Registered: July 27, 2004Reply With QuoteReport This Post
Member
posted Hide Post
I'm getting this error too. I have 7.6.4. I've created a WebService called RC_Login. Using the wsdl url of:
http:///rcaster/services/LogonService?wsdl

This happens without a problem... But when I go to create a synonym then I get error:

(FOC44563) Error in parsing WSDL :
http:///rcaster/services/LogonService?wsdl

Yes you can replace with a valid URL. If I paste that URL in my browser then I get the WS definition. I even tested from the reporting server using wget that it (the server) can talk and get this same file. No firewalls are in the way.

This is a 7.6.4 install. My initial goal besides getting a synonym setup, is to write a report that shows all the RC jobs running/queued up.

Thanks for your help.


Have used WF 5.x, 7.x w/RC, BID, MR
WAS 5.x/6.x
AIX 5.3.0
 
Posts: 29 | Location: Wine Country | Registered: October 10, 2006Reply With QuoteReport This Post
Member
posted Hide Post
OK even more wierd. Some services created synonyms but not all. But when I "sample data" for getjobsinqueue I get the following error.

(FOC44540) SOAP Request got error. Response Status : 500 ; Reason: Internal Server Error
(FOC44541) Faultcode : soapenv:Server.userException
(FOC44542) Faultstring: java.lang.NullPointerException
(FOC44544) Faultdetail: uintapp3


Have used WF 5.x, 7.x w/RC, BID, MR
WAS 5.x/6.x
AIX 5.3.0
 
Posts: 29 | Location: Wine Country | Registered: October 10, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
Michael,

It's too bad your posting was never answered - I get the same error:

 (FOC44540) SOAP Request got error. Response Status  : 500 ; Reason:  Internal
 Server Error
 (FOC44541) Faultcode  : SOAP-ENV:Server
 (FOC44542) Faultstring: Invalid lookup: RDBMS/Schemas/EDA/Procedures/DSCCALL


I'm trying to figure out if the error is with the adapter or the web service.

The people that run the web service have assured us they've restarted the web service. We've restarted the adapter.

I haven't found much on Tech Support regarding these errors. These two documents aren't any help.

Tech Support: (FOC44540) SOAP Request got error. Response Status: 500 mentions something about NLS Spanish setting .

Tech Support: (FOC44540) SOAP Request got error. Response Status : 505 mentions something about spaces in the connection attributes in edasprof.prf.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Gold member
posted Hide Post
Francis,

Did you have any luck with this?


WF 8005 MRE BID RCaster DevStu PMF 5.3.1 Hotfix 5
XP Oracle.
 
Posts: 55 | Location: UK-London | Registered: January 27, 2005Reply With QuoteReport This Post
Member
posted Hide Post
try giving token number and other criteria for webservice in where clause like
TABLE FILE AVC
PRINT
XYZ
WHERE
TOKEN EQ '123'
CONECT_TYPE EQ 'ST';
END
-EXIT


Webfocus 7.7
 
Posts: 8 | Registered: August 04, 2014Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Consuming WebService from Webfocus

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.