Focal Point
Excel Reports within frames

This topic can be found at:

October 02, 2003, 09:57 PM
Excel Reports within frames

In my application, I am allowing the users to choose the report format - HTML / PDF / Excel. Since our application uses frames, the report doesn't open up in a new window. It opens up in a frame within the same browser window. So when I want to save the Excel report or print the report, it does not allow me to do it. (If I go to File -> Save As, it saves the whole frames web page).

For the PDF format, since Acrobat provides its own menubar, I can either print it or save it.

For HTML, we have included some additional HTML code on top of the report. This basically provides an icon, which when clicked shows the whole report in a new window, allowing the users to either print it or save it.

Is there a way to either
1. Show the Excel toolbar similar to Acrobat's toolbar, within the HTML frame?
2. Include the Excel report within HTML code.

If anyone has any ideas, please let me know. Any kind of help will be appreciated.

Thanks in advance!
October 03, 2003, 06:39 PM
1. To save just the Excel document, simply click anywhere in the document and hit the F12 key. This will popup the Excel "Save As" dialog. For the EXL2K (and maybe EXL97) format, the "Save As" dialog will default to the HTML format. You can simply change the "Save As" type to MS Excel (.xls).

2. With some simple Javascript, you can change the form's TARGET attribute to _blank depending on the format choosen. This would be implemented via the form's onSubmit handler.

Hope this helps.
December 11, 2003, 05:42 PM
excel or exl2k screen output isn't really excel, no matter what they tell you.
its just a viewer.
in order to have the real excel toolbar, you have to save the output as a real excel sheet and then open it again in real excel.
December 15, 2003, 08:17 PM
This might help . . . .

Excel files can be opened in a seperate window by changing the following setting within the client machine. For XP, open Explore (not Internet Explorer), and click on "Tools" -- "Folder Options" -- "File Types" tab. Scroll down and highlight the XLS file extention. In the lower panel, click on "Change" the opens with program. Select MicroSoft Excel and save.

Now all Excel file will open in Excel, not within IE.

Let me know if this works for you.
December 16, 2003, 01:22 AM
Dave, i've got excel selected as the filetype for opening any file with an extension .xls,
and we've already got this thing opening in a separate window; thing is, its just a viewer.
The menu items on the top, for example, are IE, not excel. We're in XP.
Any thoughts??
December 16, 2003, 02:38 PM
Display the report in IE, you should be able to see the file ext (ie. ".xls" or ".xht").

From Control Panel select "Folder Options" and the click the "file Tyes" tab. Scroll down to the file's extention (noted from above). Be sure that the associated program is Excel. Select the "Advanced" button and be sure "Browse in the same window" is UN-checked. After the changes are made, click "Apply" and "OK" on the "File Types" tab. The machine will need to be rebooted for the changes to take effect. This should resolve this issue. Let me know.
December 16, 2003, 06:47 PM
Porter Thorndike
Try running the report with Excel open, this will output your report into excel instead of into a seperate Internet Explorer window.
April 07, 2004, 02:17 PM
I have a very happy user thanks to your input DAVEH...... Your input fixed the problem we were having. THANKS for posting ..... Big Grin