Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] HTML page is Just spinning after upgrade

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] HTML page is Just spinning after upgrade
 Login/Join
 
Gold member
posted
Hello,
We have upgraded webfocus from 8105M - GEN 843 to 8105M - GEN921. The HTML NO longer works,the HTML page is just spinning it was working before. After upgraded to this version8105M - GEN921 the HTML page no longer works. We have some JavaScript code in the page. . I appreciate any one help me on this issue.
Thank you,
V_Ani


 <!DOCTYPE html>
<html><head><meta id="RLT_STANDARDS_MODE_META" http-equiv="X-UA-Compatible" content="IE=Edge"><meta name="mycharsetmeta" http-equiv="Content-Type" content="text/html; charset=WINDOWS-1252"><meta name="Generation" content="Created in release 8105, Generation 4"><meta name="viewport" content="width=device-width, initial-scale=1.0">
<script type="text/javascript">
//confidential_id=IBI_OptionsScript
var bRuntimes=true;var szHtmlAlias="./ibi_html/";var is_mobile="false";var szRunTimeHtmlAlias="runTimeHtmlAlias";var cgipath="cgipath";var ib_composer="ib_composer";var map="ib_composer_map";var grid="ib_composer_grid";var emf="ib_composer_emf";var ibiOptions = new Array(cgipath,ib_composer);if(typeof(szRunTimeHtmlAlias) === 'string' && szRunTimeHtmlAlias.indexOf('/') == 0)szHtmlAlias=szRunTimeHtmlAlias;document.write('<script src="'+szHtmlAlias+'ibigbl.js" type="text/javascript"><\/script>');</script><script type="text/javascript">
//confidential_id=IBI_ibigblloadCss
if(typeof ibigblloadCss === 'function'){ibigblloadCss(null);addIntlTranslatedJS("composertrans.js");}else {alert("JavaScript alias './ibi_html/'  is not valid.");window.location("about:blank");}</script><title>HtmlPage</title>
<script type="text/javascript">
//confidential_id=clientEventHandlersJS
if(typeof(bRuntime) != 'undefined') {
var changeyr ;
var changepd;
var changewk;
var changebu;
var changeterr;
var changereg;
var changeseg;
var changeprod;
var changegrp;
var changerad ;
var changeinvrad;
var changefltr;
}
//Begin function window_onload
function window_onload() {
UpdateData();
loadjQuery();
// TODO: Add your event handler code here
//add onInitialUpdate() function to make changes before initial run of the reports
}
//End function window_onload
function loadjQuery() {
var element = document.createElement('script');
element.async = false;
element.src = '/ibi_apps/ibi_html/javaassist/jquery/jquery_min.js';
element.type = 'text/javascript';
(document.getElementsByTagName('head')[0]||document.body).appendChild(element);
var element1 = document.createElement('script');
element1.async = false;
element1.src = '/approot/baseapp/jquery.contextmenu.js';
element1.type = 'text/javascript';
(document.getElementsByTagName('head')[0]||document.body).appendChild(element1);
var element2 = document.createElement('link');
element2.async = false;
element2.href = '/approot/baseapp/jquery.contextmenu.css';
element2.type = 'text/css';
element2.rel = 'stylesheet';
(document.getElementsByTagName('head')[0]||document.body).appendChild(element2);
var element3 = document.createElement('script');
element3.async = false;
element3.src = '/ibi_apps/jquery/jquery-ui.min.js';
element3.type = 'text/javascript';
(document.getElementsByTagName('head')[0]||document.body).appendChild(element3);
var element4 = document.createElement('link');
element4.async = false;
element4.href = '/ibi_apps/jquery/jquery-ui.css';
element4.type = 'text/css';
element4.rel = 'stylesheet';
(document.getElementsByTagName('head')[0]||document.body).appendChild(element4);
var element5 = document.createElement('script');
element5.async = false;
element5.src = '/approot/baseapp/jquery.ui.position.js';
element5.type = 'text/javascript';
(document.getElementsByTagName('head')[0]||document.body).appendChild(element5);
var element6 = document.createElement('link');
element6.async = false;
element6.href = '/ibi_apps/baseapp/jquery.contextmenu.title.css';
element6.type = 'text/css';
element6.rel = 'stylesheet';
(document.getElementsByTagName('head')[0]||document.body).appendChild(element6);
}
function Run_onclick(ctrl) {
OnExecute(ctrl)
}
function button2_onclick(ctrl) {
OnExecute(ctrl)
}
 

This message has been edited. Last edited by: FP Mod Chuck,


WebFOCUS 8
Windows, All Outputs
 
Posts: 73 | Registered: April 06, 2016Report This Post
Silver Member
posted Hide Post
ive seen that happen when it does not like the javascript


WebFOCUS 8
Windows, All Outputs
 
Posts: 30 | Location: Living in Charlotte, working all over | Registered: July 13, 2015Report This Post
Virtuoso
posted Hide Post
Suggestion:

Either use F12 developer tool to find out where is the error.

Comment out all your functions and test your HTML. Then remove comment few lines at a time and test it back until you find from where the error occurs.

I do suspect code may be more tightening, missing parentheses/ellipses or too many.


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2410 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Report This Post
Gold member
posted Hide Post
As MartinY suggested, Check the browser console for any JS errors and also make sure the reference fex and JS files are pointing to the correct folder as before.


Tharun Katanguru
SBOX- 8205 DEV/TEST/PROD : 8105 8205
Linux, All Outputs
 
Posts: 52 | Location: BOWL OF PASTA | Registered: October 13, 2016Report This Post
Gold member
posted Hide Post
Martiny,I have tested after few lines of function.Now the HTML page able to load. But this file"jquery_min.js" is not in the below path. Please see the commented out function . Also I am getting other script error.I am trying to show you the script error image But I don't how load the image of the screenshot here .


 function loadjQuery() {
//var element = document.createElement('script');
//element.async = false;
//element.src = '/ibi_apps/ibi_html/javaassist/jquery/jquery_min.js';
//element.type = 'text/javascript';
//(document.getElementsByTagName('head')[0]||document.body).appendChild(element); 
 
Posts: 73 | Registered: April 06, 2016Report This Post
Gold member
posted Hide Post
V_ani,

the other script error might also be due to the absence of jquery_min.js. I am using 8105 -GEN902 and my jquery is in "/ibi_apps/ibi_html/javaassist/jquery/jquery_min.js".

As a trial and error method, you can search for jquery_min.js in your repository and copy it in the above mentioned folder and try running it again. I dont know whether this is the correct process or not but it worked for me previously.


Tharun Katanguru
SBOX- 8205 DEV/TEST/PROD : 8105 8205
Linux, All Outputs
 
Posts: 52 | Location: BOWL OF PASTA | Registered: October 13, 2016Report This Post
Gold member
posted Hide Post
Thank you all your suggestion.My Html page is working now after added this IBFS:/WFC/ path to the drill down procedures.


WebFOCUS 8
Windows, All Outputs
 
Posts: 73 | Registered: April 06, 2016Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] HTML page is Just spinning after upgrade

Copyright © 1996-2020 Information Builders