Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] GEOGRAPHIC_ROLE not being applied?
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] GEOGRAPHIC_ROLE not being applied?
 Login/Join
 
Platinum Member
posted
We are testing to upgrade to 8.2.06 and trying to create maps using the new Designer, my state abbreviation field isn't being recognized. I have GEOGRAPHIC_ROLE=USSTATE_ABBR in the master file but when I run my map with that field as the location, I see a blank map and "51 Unknown" at the bottom. When I click on that it lists all the state abbreviations. I get that it might not like our abbreviation for Washington, DC, but it should recognize the other 50 since we use the official postal service abbreviations. What am I missing?

Thanks,
Deb

This message has been edited. Last edited by: DWaybright,


WebFOCUS 8.2.03 (production), 8.2.06 (testing)
AppStudio, InfoAssist
Windows, All Outputs
 
Posts: 135 | Location: Indiana | Registered: December 05, 2017Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Do you have the state associated with a country? Even though USSTATE_ABBR has a geographic role, when I try to map it in InfoAssist, I first right click and select Map As, State/Province which opens a dialogue that has me define what it depends on. In this case, the Geographic Role of State Depends on Geographic Role of Country which can be stored as either another Field or hard coded to say United States.

BTW, to avoid all of these extra clicks, just change the column name to US_STATE_ABBR and add a COUNTRY of United States to the table.

This message has been edited. Last edited by: BabakNYC,


WebFOCUS 8206, Unix, Windows
 
Posts: 1713 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Platinum Member
posted Hide Post
@BabakNYC
I tried changing it from USSTATE_ABBR to US_STATE_ABBR and it does have a country associated with it but that didn't help.
In InfoAssist I do get the popup window to choose the geographic role and set the country role, but I don't get that in Designer. None of it works. Frowner


WebFOCUS 8.2.03 (production), 8.2.06 (testing)
AppStudio, InfoAssist
Windows, All Outputs
 
Posts: 135 | Location: Indiana | Registered: December 05, 2017Reply With QuoteReport This Post
Virtuoso
posted Hide Post
I just tried it in 8206.05 and US_STATE_ABBR worked in designer. Does your master have a business view? I have a BV and COUNTRY and STATE are in a geography dim.

Also, what gen of 82xx are you running? You may need to open a case with IB tech support.


WebFOCUS 8206, Unix, Windows
 
Posts: 1713 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Platinum Member
posted Hide Post
We have 8206.09 installed. We don't use Business Views.
I think you are correct about opening a case.
Thanks.


WebFOCUS 8.2.03 (production), 8.2.06 (testing)
AppStudio, InfoAssist
Windows, All Outputs
 
Posts: 135 | Location: Indiana | Registered: December 05, 2017Reply With QuoteReport This Post
Virtuoso
posted Hide Post
I just tested it without a BV and it's not working. I believe a BV Hierarchy would be necessary in the Master file if you want to use Designer for now. Alternatively, you can use InfoAssist which as you mentioned will prompt you for the hierarchical relationship between Country and state.


WebFOCUS 8206, Unix, Windows
 
Posts: 1713 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Platinum Member
posted Hide Post
BabakNYC,
Thanks for testing that out. It will certainly inform our path moving forward.


WebFOCUS 8.2.03 (production), 8.2.06 (testing)
AppStudio, InfoAssist
Windows, All Outputs
 
Posts: 135 | Location: Indiana | Registered: December 05, 2017Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] GEOGRAPHIC_ROLE not being applied?

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.