Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Parameter Prompting
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Parameter Prompting
 Login/Join
 
Platinum Member
posted
Hai

In InfoAssist you can add parameters for data selection a run-time. When you add a parameter, it becomes a field container into which you can add one or more measures and dimensions. See page 66 InfoAssist+ 8.2.04

To be able to use this functionality, one should adapt ‘Managed Reporting’ in the Administration Console/Parameter Promping.
Give it the value 'Run with default values'.

But then a lot of existing reports/fexes are hit. Asking for a parameter value.

Is there a way of setting this parameter only for specific reports, so it won't effect other things?

regards
Ron

This message has been edited. Last edited by: FP Mod Chuck,


WebFOCUS AppStudio 8.2.02M
WebFocus Datamanagement Console 8.1M
DMC
 
Posts: 109 | Registered: August 29, 2014Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Ron,
I'm not really sure what you are asking. Only reports that use the parameter should prompt for it. If you are using the Page Designer, it will put the parameters at the top for all the reports on the page, but it will only affect the reports that reference that parameter (amper variable). Does that help?

--Deb


WebFOCUS 8.2.03
AppStudio, InfoAssist
Windows, All Outputs
 
Posts: 120 | Location: Indiana | Registered: December 05, 2017Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Hai Deb

no, that is not what I mean. When we change the general setting of 'Managed Reporting’ suddenly a lot of existing fexes/reports/dashboards behave differently. Asking for parameter input.
That is not what we want.


WebFOCUS AppStudio 8.2.02M
WebFocus Datamanagement Console 8.1M
DMC
 
Posts: 109 | Registered: August 29, 2014Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Strictly speaking, autoprompt prompts for uninitialized parameters. Usually, those are signs of code problems. My advise is to take a good look at those reports that now suddenly prompt for parameters, as you may have code issues there.

Unfortunately, autoprompt is not smart enough to detect unreachable code, which (at least in our case) is often the reason parameters remain uninitialized.
We either comment such code out, or split it off to a separate file.

The other frequent culprit is -READFILE, which "creates" new parameters on the fly. There again, autoprompt is not quite smart enough. Adding -DEFAULTH for those parameters (after -READFILE) hides them from autoprompt.
That gets messy with dynamically generated TABLE requests though.

Making autoprompt smarter about such cases will very probably slow it down significantly - but even then - some of those cases cannot be detected without actually executing the code in between.

Finally, autoprompt prompts get funky when you initialize a parameter after its first use. It for input, but still manages to put a value in the field for that parameter. Those cases can be hard to find, but they are actual uninitialized parameters and therefore bugs.


WebFOCUS 8.1.03, Windows 7-64/2008-64, IBM DB2/400, Oracle 11g & RDB, MS SQL-Server 2005, SAP, PostgreSQL 11, Output: HTML, PDF, Excel 2010
: Member of User Group Benelux :
 
Posts: 1641 | Location: Enschede, Netherlands | Registered: August 12, 2010Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Ok, so when you have (like we) I very large install base, it is very complicated to start using parameter containers in InfoAssist (to be used in the new InfoApp) because it is hard to find out which existing programs will behave differently once 'Managed Reporting' is changed?


WebFOCUS AppStudio 8.2.02M
WebFocus Datamanagement Console 8.1M
DMC
 
Posts: 109 | Registered: August 29, 2014Reply With QuoteReport This Post
Virtuoso
posted Hide Post
If you have a large install base and you start changing settings, that is always the case.

quote:
once 'Managed Reporting' is changed

I have no idea what this means, but perhaps someone at IBI does. You should probably open a case anyway.


WebFOCUS 8.1.03, Windows 7-64/2008-64, IBM DB2/400, Oracle 11g & RDB, MS SQL-Server 2005, SAP, PostgreSQL 11, Output: HTML, PDF, Excel 2010
: Member of User Group Benelux :
 
Posts: 1641 | Location: Enschede, Netherlands | Registered: August 12, 2010Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Parameter Prompting

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.