Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [solved] JavaScript alias './ibi_html/' is not valid
Go
New
Search
Notify
Tools
Reply
  
[solved] JavaScript alias './ibi_html/' is not valid
 Login/Join
 
Master
posted
Does anyone know any other causes for this error message besides setting setting IBI_GZIP.enabled to True? This is only happening for reports created with Application Studio. If I create it with DS there are no problems. In my other environments setting IBI_GZIP.enabled has resolved this issue. But in my staging environment it does not seem to help.

This is the javascript function that produces the error message.

quote:
if(typeof ibigblloadCss === 'function'){ibigblloadCss(null);addIntlTranslatedJS("composertrans.js");}else {alert("JavaScript alias './ibi_html/' is not valid.");


not sure where to go to chase this down.

This message has been edited. Last edited by: eric.woerle,


Eric Woerle
8.1.05M Gen 913- Reporting Server Unix
8.1.05 Client Unix
Oracle 11.2.0.2
 
Posts: 750 | Location: Warrenville, IL | Registered: January 08, 2013Reply With QuoteReport This Post
Guru
posted Hide Post
Don't have a solution for this, but you could check if you have both composertrans.js and composertrans.js_closure.gz in ibi/WebFOCUS8x/ibi_html/javaassist/intl/EN


Test: WF 8.2
Prod: WF 8.2
DB: Progress, REST, IBM UniVerse/UniData, SQLServer, MySQL, PostgreSQL, Oracle, Greenplum, Athena.
 
Posts: 423 | Location: Europe | Registered: February 05, 2007Reply With QuoteReport This Post
Master
posted Hide Post
I think the problem ended up being that I was missing a custom CSS file (That I forgot to move into the environment) coupled with needing to clear my cache out. The issue has now resolved itself.

Thanks for the response Frans


Eric Woerle
8.1.05M Gen 913- Reporting Server Unix
8.1.05 Client Unix
Oracle 11.2.0.2
 
Posts: 750 | Location: Warrenville, IL | Registered: January 08, 2013Reply With QuoteReport This Post
Expert
posted Hide Post
We found this issue when it was suggested to try App Studio 8.1.05 html file on an 8.1.04 installation.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.06OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6252 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [solved] JavaScript alias './ibi_html/' is not valid

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.