Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     ReportCaster in not picking up the job
Go
New
Search
Notify
Tools
Reply
  
ReportCaster in not picking up the job
 Login/Join
 
<Navin>
posted
Hi

When i submit the job in the reportcaster in hte run once immediately fashion , the jobs takes long time to finish. the logs are not getting updated properly .

after an hour of delay or more , i am getting the following error message .

***********************************************


SET DISTRIBUTE=OFF
Task error:Server disconnected, cause 32016 Eda code -12
No report to distribute.

***********************************************

Any idea why its behaving so ??
 
Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Looks like SET DISTRIBUTE=OFF was coded into the focexec that you've created. Can you remove it?
 
Posts: 140 | Registered: May 02, 2007Reply With QuoteReport This Post
Expert
posted Hide Post
Another thing to explore is the amount of data you are retrieving. Does the focexec run ok interactively?

Generally, a -12 means you are trying to return too much data to the client.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Reply With QuoteReport This Post
<Navin>
posted
some times i am getting this error.

************************************************

SET DISTRIBUTE=OFF

FATAL ERROR IN DATABASE I/O. FOCUS TERMINATING ERROR WRITING FOCSORT
, PAGE 4, CODE 0xffffffff

Task error:Server disconnected, cause 32026 Eda code -12
No report to distribute.

************************************************

But i havent hard coded

-SET DISTRIBUTE = OFF;

anywhere in the fex.
 
Reply With QuoteReport This Post
Platinum Member
posted Hide Post
that's a little different, the report crashed and didn't complete. Hence it would make sense that caster didn't distribute a report.

A better error message would've been nicer, though
 
Posts: 140 | Registered: May 02, 2007Reply With QuoteReport This Post
<Navin>
posted
is there any way that i can get the error message correctly ??

or how can i make the report not to crash.
 
Reply With QuoteReport This Post
Guru
posted Hide Post
I once opened a case on this mysterious SET DISTRIBUTE=OFF. This is the answer I got back from IBI tech support:
quote:

From what I see this is a command issued from within a focexec or possibly
internally from somewhere but it has no bearing on why your reports
are not being produced. I don't think it is important to pursue this.



(Prod: WebFOCUS 7.7.03: Win 2008 & AIX hub/Servlet Mode; sub: AS/400 JDE; mostly Self Serve; DBs: Oracle, JDE, SQLServer; various output formats)
 
Posts: 391 | Location: California | Registered: April 14, 2003Reply With QuoteReport This Post
<Navin>
posted
Thanks Selph.

Is that anything you did for preventing the report from getting crashed or finally how you got the output, if you faced the same issue ?
 
Reply With QuoteReport This Post
Guru
posted Hide Post
My symptoms were different than yours. This was a case where the job ran sometimes (all times of day when I could be available to test myself) , and sometimes not (at some inconvienient time of day, like 4am or something when someone wanted to schedule it). Even with the &ECHO on, I never saw any error message in the log when it did not run. This mysterious SET DISTRIBUTE=OFF was seen in the logs both for success and failure.
I finally concluded that even though all back-end systems from which the data came were supposed to be "up" at that time of day, they must have had some process going on that crashed the job. Why no error message was seen in the Report Caster log, I never figured out.


(Prod: WebFOCUS 7.7.03: Win 2008 & AIX hub/Servlet Mode; sub: AS/400 JDE; mostly Self Serve; DBs: Oracle, JDE, SQLServer; various output formats)
 
Posts: 391 | Location: California | Registered: April 14, 2003Reply With QuoteReport This Post
Expert
posted Hide Post
Navin,

Referring to my post above, have you run the report interactively yet? You will get better error messages than what you get in Report Caster.

Please let us know the results.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Reply With QuoteReport This Post
<Navin>
posted
Ginny,

I dono how to run the report interactively.
can you tell me how??
 
Reply With QuoteReport This Post
Expert
posted Hide Post
If you have Developer Studio, you can run it from there. Otherwise, run it from a browser:

[URL=http://your_webserver_name/ibi_apps/WFServlet?IBIF_ex=name_of_focexec&IBIAPP_app=name_directory_where_foxecec_is][/URL]

To keep it simple, put -DEFAULTS in the program so that you don't get prompted for variables if there are any.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Reply With QuoteReport This Post
<Navin>
posted
Ok Ginnay

let me try that out and let you know
 
Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Ginny: Right on the mark with the -12 diagnosis. Navin needs a limit on records read/retrieved and run it interactively. If it works let it run full blown and see if that works interactively.
Navin may not have ability to run a dev studio fex. So url from browser is excellent idea.
Navin: Keep us posted.

Ira
5.3.6 (wf)
533 (aix)


aix-533,websphere 5.1.1,apache-2.0,
wf 538(d), 537 (p),
==============
7.6.11 (t) aix 5312
websphere 6.1.19
apache 2.0
 
Posts: 195 | Registered: October 27, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
And I forgot two things. Make sure that the output format, just for online testing, is HTML. That way you'll be able to do a View Source and check to see if there are any error messages at the end of the html.

You can't do that with EXL2K and PDF formats.

Once you get the issue figured out, you can put the format back to what it is supposed to be.

And the second thing is that if the program fails when run online and it has a lot of steps, start putting a -EXIT after each step till you figure out the one that is failing.

Thanks for the kind words, Ira. I used to do regional EDA work for IBI in the 90's and got very familiar with the minus error codes. Smiler


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Reply With QuoteReport This Post
Gold member
posted Hide Post
An error pointing to FOCSORT indicates that the data being sorted by FOCUS is too large. See if you can limit the data being sorted. One option is to also use TABLEF if possible. I don't know what platform you are running on, but look into turning EXTSORT=ON. The options available differ based on which operating system your reporting server is on.


Diptesh
WF 7.1.7 - AIX, MVS
 
Posts: 79 | Location: Warren, NJ, USA | Registered: October 25, 2006Reply With QuoteReport This Post
<Navin>
posted
Hi Diptesh,

we are running on UNIX platform with Oracle as the backend.
 
Reply With QuoteReport This Post
<Navin>
posted
Hi

I have included both the

TABLEF and EXTSORT = ON in the report.

Now the error is specifically like

------------------------------------------------

THE PRINT LINE EXCEEDS THE MAXIMUM LINE WIDTH. WIDTH IS: 2530

Task error: THE PRINT LINE EXCEEDS THE MAXIMUM LINE WIDTH. WIDTH IS: 2530

------------------------------------------------

Can anyone help on this ??
 
Reply With QuoteReport This Post
Virtuoso
posted Hide Post
You're running a job in ReportCaster that has over 2500 character/width? What kind of ouput are you expecting?


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Reply With QuoteReport This Post
<Navin>
posted
Darin ,

in the fex file i have included like

TABLE FILE HOLD
PRINT
-INCLUDE printcols
END

------printcols.fex ------------------

-SET &CNTR1 = 1;
-LOOP1
-IF (&CNTR1 LT &TOT_COLS) THEN STEP1 ELSE STEP2;
-STEP1
A&CNTR1 AS '&F.&CNTR1'
-SET &CNTR1 = &CNTR1 + 1;
-GOTO LOOP1
-STEP2
-SET &CNTR1 = 0;

---------------------------------------

A1 , A2 , ... are the columns which i dynamically take from the SQL Query fex.(total number will be in &TOT_COLS)

'&F' variable contains the alias name for the 'A' columns.

so i take a loop for that.

while doing this i am getting the above error.
 
Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Navin, I would suggest the following to debug your job.

1. Run it from dev studio or mre does it work outside of RC?
2. If not then shorten, the number of PRINT columns to 5, and try that? Does it work expand to 10 etc.. until it fails...
3. Once it fails, issue SET PANEL=500 -- right before the final table that causes this error.

Let us know what happens..

Ira

WF 5.3.6 AIX 533


aix-533,websphere 5.1.1,apache-2.0,
wf 538(d), 537 (p),
==============
7.6.11 (t) aix 5312
websphere 6.1.19
apache 2.0
 
Posts: 195 | Registered: October 27, 2006Reply With QuoteReport This Post
Virtuoso
posted Hide Post
But what FORMAT? PDF, HTML,EXCEL, etc. I think Ira is going along the same path. If you're using RC, I'm assuming you want some kind of output (thought that does not always have to be the case). What kind of output is going to allow you to display 2500+ characters wide?

The SET PANEL may resolve your problem


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Reply With QuoteReport This Post
<Navin>
posted
All,

I am getting the following error now . . .
-------------------------------------------
SET DISTRIBUTE=OFF
CRITICAL ERROR IN EXTERNAL SORT. RETURN CODE IS: 00000332
Task error:Server disconnected, cause 32026 Eda code -12
No report to distribute.
-------------------------------------------

I have included the following code . .

-------------------------------------------

SET PANEL = 500
SET EXTSORT=ON

-------------------------------------------

Any clues ??
 
Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Running out of available sort space? Can't tell what platform as external sorts are usually more specific to an MVS environment, but your profile says Unix. Still, if you've not enough resource, you would get this error.


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Permissions to write to directory for sorting?

Ira

AIX 533 wf 5.3.x (Prod)


aix-533,websphere 5.1.1,apache-2.0,
wf 538(d), 537 (p),
==============
7.6.11 (t) aix 5312
websphere 6.1.19
apache 2.0
 
Posts: 195 | Registered: October 27, 2006Reply With QuoteReport This Post
<Navin>
posted
Ira,

we have everything set.

The schedules from other reports are using the same directory and create their temp files.

I am having a constant check on the size of the directory also. they never gets full.we have ample space too.

The same query runs for the online reporting also.It fails in the ReportCaster alone.
 
Reply With QuoteReport This Post
Expert
posted Hide Post
I would love an official answer from IBI as we are occasionally getting errors like this one.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     ReportCaster in not picking up the job

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.