Focal Point
[CASE-OPENED] ERROR CONNECTING TO SQL DATABASE

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/3247080795

January 17, 2011, 03:14 AM
Yangyang
[CASE-OPENED] ERROR CONNECTING TO SQL DATABASE
Hi all,

I saw below,but It's not work for me ..

http://forums.informationbuild...391010782#9391010782

below is my error:

(FOC1261) PHYSICAL INTERFACE NOT FOUND FOR SUFFIX SQLMSS. MODULE NAME : OLEFOC
(FOC1262) THE FOLLOWING NATIVE ERROR MESSAGE(S) CAPTURED :
(FOC1260) Loading D:\ibi\64bit\srv76\home\bin\olefoc.dll: RebindStatus: failed
to bind C:\Windows\system32\KERNEL32.dll
(FOC1263) THE CURRENT ENVIRONMENT VARIABLES FOR SUFFIX SQLMSS ARE :
(FOC1260) PATH : D:\ibi\64bit\srv76\home\bin
(FOC1260) C:\Windows\system32
(FOC1260) C:\Windows
(FOC1260) C:\Windows\System32\Wbem
(FOC1260) C:\Windows\System32\WindowsPowerShell\v1.0\
(FOC1260) C:\Program Files\Microsoft SQL Server\80\Tools\binn
(FOC1260) C:\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn\
(FOC1260) C:\Program Files\Microsoft SQL Server\90\Tools\binn\
(FOC1260) C:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn\
(FOC1260) C:\Microsoft SQL Server 2005 JDBC Driver\sqljdbc_1.2\enu\
(FOC1400) SQLCODE IS -1 (HEX: FFFFFFFF)
(FOC1400) SQLCODE IS -1 (HEX: FFFFFFFF)
(FOC1488) SQL INTERFACE HAS NOT BEEN INSTALLED OR COULD NOT BE INITIALIZED
: Physical interface not found for SUFFIX=SQLMSS . Module name: OLEFOC
(FOC1400) SQLCODE IS -1 (HEX: FFFFFFFF)
(FOC1488) SQL INTERFACE HAS NOT BEEN INSTALLED OR COULD NOT BE INITIALIZED
: Physical interface not found for SUFFIX=SQLMSS . Module name: OLEFOC
(FOC1479) ERROR CONNECTING TO SQL DATABASE

I got this error...


Thanks,
James

This message has been edited. Last edited by: Kerry,


WebFOCUS 7.6.8
WebFOCUS 7.6.10
BI
FLEX
.NET
January 17, 2011, 06:27 AM
Ramkumar - Webfous
Hi Yang,

Have you created the Data adapter for MS Sql Server? If so are you able to get the results while Testing the adapter ?

Thanks,
Ram


Thanks,

Ramkumar.
WebFOCUS/Tableau
Webfocus 8 / 7.7.02
Unix, Windows
HTML/PDF/EXCEL/AHTML/XML/HTML5
January 17, 2011, 07:49 AM
GamP
You're running on a 64 bit machine. I think the sql server installation is also a 64 bit system.
The bind however is to the 32 bit windows kernel ... so that will never work. You should check the path settings of your system environment to be sure that only 64 bit stuff is being referenced. I see several directories with '(x86)' specified. That is the 32 bit version...


GamP

- Using AS 8.2.01 on Windows 10 - IE11.
in Focus since 1988
January 17, 2011, 08:43 PM
Yangyang
Hi Ramkumar,

Thanks for you reply.I'm created the Data adapter for MS Sql Server. It's work before I reboot the Webfocus Server machine..
When I reboot the machine, and click I found the "Testing the adapter" got the top error.

Hi GamP,
It's work for me before(32bit SQL2005),when I reboot the machine,the error happend.

Thanks,
James


WebFOCUS 7.6.8
WebFOCUS 7.6.10
BI
FLEX
.NET
January 18, 2011, 01:07 AM
Ramkumar - Webfous
May be you can try deleting and recreating the adapter one more time, and try testing that...

The adapter might have got corrupted on the restart...

Please get on to Techsupport, I this doesnt help out...


Thanks,

Ramkumar.
WebFOCUS/Tableau
Webfocus 8 / 7.7.02
Unix, Windows
HTML/PDF/EXCEL/AHTML/XML/HTML5
January 18, 2011, 01:18 AM
Yangyang
Hi Ramkumar,

I'm open a case in Techsupport. Thanks.

Thanks,
James


WebFOCUS 7.6.8
WebFOCUS 7.6.10
BI
FLEX
.NET
January 18, 2011, 05:14 AM
Ramkumar - Webfous
quote:
try deleting and recreating the adapter one more time, and try testing that


Hi Yang,

Did you try that ??


Thanks,

Ramkumar.
WebFOCUS/Tableau
Webfocus 8 / 7.7.02
Unix, Windows
HTML/PDF/EXCEL/AHTML/XML/HTML5